Zeptomoby.OrbitTools.Track Namespace

[image]

OrbitTools Track Library Documentation
Zeptomoby.OrbitTools.Track Namespace
Send Feedback

Classes

 | Class | Description
Public class | Acquire | Class to encapsulate satellite-to-satellite, satellite-to-site, and site-to-satellite acquisition.
Public class | Apsis | Class to encapsulate data associated with an orbital apsis.
Public class | AzElTime | Class to encapsulate satellite azimuth and elevation information at a given moment in time.
Public class | CircularBeamProfile | Class that describes a beam with uniform circular density.
Public class | HorizonMask | Defines a section of the sky which is not viewable.
Public class | LatLonTime | Class to encapsulate latitude/longitude pair and a time.
Public class | Node | Class to encapsulate data associated with an orbital node.
Public class | PassData | Class to encapsulate satellite AOS (rise) data, LOS (set) data, and MAX (maximum elevation above horizon) data.
Public class | PassSegment | Defines a segment of a satellite pass.
Public class | PeriodInfo<(Of <(<'T>)>)> | Class to encapsulate a time period and associated "content", which is a list of type T. The period start and stop times are rounded to the nearest second.
Public class | Schedule<(Of <(<'T>)>)> | Class to manage a list of sorted time periods, and provide information regarding which periods overlap in time. Each time period has optional "content", which is a list of type T.
Public class | Solar | Utility class used to provide Sun-related data.
Public class | Station | An Earth location that supports sky mask capability.
Public class | Track | This class contains the top-level methods that comprise the core functionality of the OrbitTools Track Library.
Public class | Utility | Class containing miscellaneous utility functions.

Interfaces

 | Interface | Description
Public interface | IBeamProfile | Interface that describes a beam of arbitrary cross-sectional shape.
Public interface | IMask | Interface used to define mask parameters.

Send comments on this topic to mfh@zeptomoby.com

Copyright © 2012-2020 Michael F. Henry


Acquire Class

[image]

OrbitTools Track Library Documentation
Acquire Class
Members See Also Send Feedback
Class to encapsulate satellite-to-satellite, satellite-to-site, and site-to-satellite acquisition.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public sealed class Acquire
Visual Basic
Public NotInheritable Class Acquire
Visual C++
public ref class Acquire sealed

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..Acquire

See Also

Acquire Members
Zeptomoby.OrbitTools.Track Namespace


Acquire Members

[image] [image]

OrbitTools Track Library Documentation
Acquire Members
Acquire Class Constructors Methods See Also Send Feedback

The Acquire type exposes the following members.

Constructors

 | Name | Description
Public method | Acquire(Satellite, IList<(Of <<'(Site>)>>), DateTime, DateTime) | Constructor used for satellite-to-site acquisition.
Public method | Acquire(Site, IList<(Of <<'(Satellite>)>>), DateTime, DateTime) | Constructor used for site-to-satellite acquisition.
Public method | Acquire(Satellite, IList<(Of <<'(Satellite>)>>), DateTime, DateTime, Double) | Constructor used for satellite-to-satellite acquisition.

Methods

 | Name | Description
Public method | AcquireAll | Calculates when the primary object can simultaneously acquire all the target objects.
Public method | AcquireAny | Calculates when the primary object can acquire any object in the list of targets.
Public method | AcquireMax | Calculates when the primary satellite can simultaneously acquire a maximum number of satellites in the list of targets.
Public method | AcquireMin | Calculates when the primary satellite can simultaneously acquire a minimum number of satellites in the list of targets.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OriginPlaneCoord(Vector, Vector) | Determine the azimuth and elevation coordinates of a point in ECI coordinate space relative to the origin plane of another point.
 | OriginPlaneCoord(Satellite, Satellite, DateTime) | Determine the azimuth and elevation coordinates of a target satellite relative to a plane containing an observing satellite.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Acquire Class


Acquire Constructor

[image] [image]

OrbitTools Track Library Documentation
Acquire Constructor
Acquire Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Acquire(Satellite, IList<(Of <<'(Site>)>>), DateTime, DateTime) | Constructor used for satellite-to-site acquisition.
Public method | Acquire(Site, IList<(Of <<'(Satellite>)>>), DateTime, DateTime) | Constructor used for site-to-satellite acquisition.
Public method | Acquire(Satellite, IList<(Of <<'(Satellite>)>>), DateTime, DateTime, Double) | Constructor used for satellite-to-satellite acquisition.

See Also

Acquire Class
Acquire Members


Acquire Constructor (, IList(), DateTime, DateTime)

[image]

OrbitTools Track Library Documentation
Acquire Constructor (, IList<(Of <(<'>)>)>, DateTime, DateTime)
Acquire Class See Also Send Feedback
Constructor used for satellite-to-site acquisition.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Acquire(
    Satellite primary,
    IList<Site> targets,
    DateTime t1,
    DateTime t2
)
Visual Basic
Public Sub New ( _
    primary As Satellite, _
    targets As IList(Of Site), _
    t1 As DateTime, _
    t2 As DateTime _
)
Visual C++
public:
Acquire(
    Satellite^ primary,
    IList<Site^>^ targets,
    DateTime t1,
    DateTime t2
)

Parameters

primary
Type: Satellite
The primary satellite.
targets
Type: System.Collections.Generic..::..IList<(Of <(<'Site>)>)>
The target earth sites.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The stop time.

See Also

Acquire Class
Acquire Overload


Acquire Constructor (, IList(), DateTime, DateTime)

[image]

OrbitTools Track Library Documentation
Acquire Constructor (, IList<(Of <(<'>)>)>, DateTime, DateTime)
Acquire Class See Also Send Feedback
Constructor used for site-to-satellite acquisition.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Acquire(
    Site primary,
    IList<Satellite> targets,
    DateTime t1,
    DateTime t2
)
Visual Basic
Public Sub New ( _
    primary As Site, _
    targets As IList(Of Satellite), _
    t1 As DateTime, _
    t2 As DateTime _
)
Visual C++
public:
Acquire(
    Site^ primary,
    IList<Satellite^>^ targets,
    DateTime t1,
    DateTime t2
)

Parameters

primary
Type: Site
The primary earth site.
targets
Type: System.Collections.Generic..::..IList<(Of <(<'Satellite>)>)>
The target satellites.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The stop time.

See Also

Acquire Class
Acquire Overload


Acquire Constructor (, IList(), DateTime, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Acquire Constructor (, IList<(Of <(<'>)>)>, DateTime, DateTime, Double)
Acquire Class See Also Send Feedback
Constructor used for satellite-to-satellite acquisition.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Acquire(
    Satellite primary,
    IList<Satellite> targets,
    DateTime t1,
    DateTime t2,
    double kmAltitude
)
Visual Basic
Public Sub New ( _
    primary As Satellite, _
    targets As IList(Of Satellite), _
    t1 As DateTime, _
    t2 As DateTime, _
    kmAltitude As Double _
)
Visual C++
public:
Acquire(
    Satellite^ primary,
    IList<Satellite^>^ targets,
    DateTime t1,
    DateTime t2,
    double kmAltitude
)

Parameters

primary
Type: Satellite
The primary satellite.
targets
Type: System.Collections.Generic..::..IList<(Of <(<'Satellite>)>)>
The target satellites.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The stop time.
kmAltitude
Type: System..::..Double
Two satellites are considered eclipsed by the earth when any point on a line between the two falls below this altitude.

Remarks

A satellite can "acquire" another satellite when its view of that satellite is not obstructed by the earth. A target satellite is considered eclipsed by the earth when any point on a line connecting the primary satellite and the target satellite falls below the altitude "kmAltitude". The altitude is relative to the surface of the earth ellipsoid model (given by the primary satellite). Increase this value to avoid generating acquire times that would require a communication link between the two satellites to pass through the earth's atmosphere.

See Also

Acquire Class
Acquire Overload


Acquire Methods

[image] [image]

OrbitTools Track Library Documentation
Acquire Methods
Acquire Class See Also Send Feedback

The Acquire type exposes the following members.

Methods

 | Name | Description
Public method | AcquireAll | Calculates when the primary object can simultaneously acquire all the target objects.
Public method | AcquireAny | Calculates when the primary object can acquire any object in the list of targets.
Public method | AcquireMax | Calculates when the primary satellite can simultaneously acquire a maximum number of satellites in the list of targets.
Public method | AcquireMin | Calculates when the primary satellite can simultaneously acquire a minimum number of satellites in the list of targets.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OriginPlaneCoord(Vector, Vector) | Determine the azimuth and elevation coordinates of a point in ECI coordinate space relative to the origin plane of another point.
 | OriginPlaneCoord(Satellite, Satellite, DateTime) | Determine the azimuth and elevation coordinates of a target satellite relative to a plane containing an observing satellite.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Acquire Class


AcquireAll Method

[image]

OrbitTools Track Library Documentation
Acquire..::..AcquireAll Method
Acquire Class See Also Send Feedback
Calculates when the primary object can simultaneously acquire all the target objects.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Schedule<IEciObject> AcquireAll()
Visual Basic
Public Function AcquireAll As Schedule(Of IEciObject)
Visual C++
public:
Schedule<IEciObject^>^ AcquireAll()

Return Value

A schedule of acquisition time periods.

See Also

Acquire Class


AcquireAny Method

[image]

OrbitTools Track Library Documentation
Acquire..::..AcquireAny Method
Acquire Class See Also Send Feedback
Calculates when the primary object can acquire any object in the list of targets.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Schedule<IEciObject> AcquireAny()
Visual Basic
Public Function AcquireAny As Schedule(Of IEciObject)
Visual C++
public:
Schedule<IEciObject^>^ AcquireAny()

Return Value

A schedule of acquisition time periods.

See Also

Acquire Class


AcquireMax Method

[image]

OrbitTools Track Library Documentation
Acquire..::..AcquireMax Method
Acquire Class See Also Send Feedback
Calculates when the primary satellite can simultaneously acquire a maximum number of satellites in the list of targets.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Schedule<IEciObject> AcquireMax()
Visual Basic
Public Function AcquireMax As Schedule(Of IEciObject)
Visual C++
public:
Schedule<IEciObject^>^ AcquireMax()

Return Value

A schedule of acquisition time periods.

See Also

Acquire Class


AcquireMin Method

[image]

OrbitTools Track Library Documentation
Acquire..::..AcquireMin Method
Acquire Class See Also Send Feedback
Calculates when the primary satellite can simultaneously acquire a minimum number of satellites in the list of targets.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Schedule<IEciObject> AcquireMin()
Visual Basic
Public Function AcquireMin As Schedule(Of IEciObject)
Visual C++
public:
Schedule<IEciObject^>^ AcquireMin()

Return Value

A schedule of acquisition time periods.

See Also

Acquire Class


OriginPlaneCoord Method

[image] [image]

OrbitTools Track Library Documentation
Acquire..::..OriginPlaneCoord Method
Acquire Class See Also Send Feedback

Overload List

Name | Description
OriginPlaneCoord(Vector, Vector) | Determine the azimuth and elevation coordinates of a point in ECI coordinate space relative to the origin plane of another point.
OriginPlaneCoord(Satellite, Satellite, DateTime) | Determine the azimuth and elevation coordinates of a target satellite relative to a plane containing an observing satellite.

See Also

Acquire Class
Acquire Members


OriginPlaneCoord Method (, )

[image]

OrbitTools Track Library Documentation
Acquire..::..OriginPlaneCoord Method (, )
Acquire Class See Also Send Feedback
Determine the azimuth and elevation coordinates of a point in ECI coordinate space relative to the origin plane of another point.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static AzEl OriginPlaneCoord(
    Vector posA,
    Vector posB
)
Visual Basic
Public Shared Function OriginPlaneCoord ( _
    posA As Vector, _
    posB As Vector _
) As AzEl
Visual C++
public:
static AzEl^ OriginPlaneCoord(
    Vector^ posA,
    Vector^ posB
)

Parameters

posA
Type: Vector
The first coordinate point.
posB
Type: Vector
The second coordinate point.

Return Value

An AzEl object containing the azimuth and elevation of the second point. The data is relative to the first point's origin plane.

Remarks

This method determines the azimuth and elevation coordinates of a target point relative to the position of an observing point in its "origin plane". The origin plane contains the observing point and the ECI coordinate space origin. The origin plane is further oriented such that the intersection line of the plane and the X-Y plane forms a right angle with the line between the observing point and the origin. Note that for a point in the X-Y plane, the origin plane and the X-Y plane are the same.

For an observing point on the origin plane, azimuth 0 always points to the axis origin, and proceeds clockwise when viewed from the direction of the positive Z-axis. Azimuth is always in the range [0, 2*PI).

Positive elevation indicates elevation "above" the origin plane (towards the direction of the positive Z-axis), and negative elevation indicates elevation "below" the origin plane (towards the negative Z-axis). Elevation is always in the range [-PI/2, PI/2].

See Also

Acquire Class
OriginPlaneCoord Overload


OriginPlaneCoord Method (, , DateTime)

[image]

OrbitTools Track Library Documentation
Acquire..::..OriginPlaneCoord Method (, , DateTime)
Acquire Class See Also Send Feedback
Determine the azimuth and elevation coordinates of a target satellite relative to a plane containing an observing satellite.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static AzElTime OriginPlaneCoord(
    Satellite satA,
    Satellite satB,
    DateTime utc
)
Visual Basic
Public Shared Function OriginPlaneCoord ( _
    satA As Satellite, _
    satB As Satellite, _
    utc As DateTime _
) As AzElTime
Visual C++
public:
static AzElTime^ OriginPlaneCoord(
    Satellite^ satA,
    Satellite^ satB,
    DateTime utc
)

Parameters

satA
Type: Satellite
The observing satellite.
satB
Type: Satellite
The target satellite.
utc
Type: System..::..DateTime
The time for which the coordinates are calculated (UTC).

Return Value

A AzElTime object containing the time, the azimuth in radians, and the elevation in radians.

Remarks

This method determines the azimuth and elevation coordinates of a target satellite relative to the position of an observing satellite in its "origin plane". The origin plane contains the observing satellite and the ECI coordinate space origin (center of the earth). The origin plane is further oriented such that the intersection line of the plane and the earth's equatorial plane forms a right angle with the line between the observing satellite and the origin. Note that when a satellite is in the equatorial plane, the origin plane and the equatorial plane are the same.

For an observing satellite on the origin plane, azimuth 0 always points to the center of the earth, and proceeds clockwise when viewed from the direction of the earth's north pole. Azimuth is always in the range [0, 2*PI).

Positive elevation indicates elevation "above" the origin plane (towards the direction of the earth's north pole), and negative elevation indicates elevation "below" the origin plane (towards the earth's south pole). Elevation is always in the range [-PI/2, PI/2].

See Also

Acquire Class
OriginPlaneCoord Overload


Apsis Class

[image]

OrbitTools Track Library Documentation
Apsis Class
Members See Also Send Feedback
Class to encapsulate data associated with an orbital apsis.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class Apsis : LatLonTime
Visual Basic
Public Class Apsis _
    Inherits LatLonTime
Visual C++
public ref class Apsis : public LatLonTime

Inheritance Hierarchy

System..::..Object
LatLon
Zeptomoby.OrbitTools.Track..::..LatLonTime
Zeptomoby.OrbitTools.Track..::..Apsis

See Also

Apsis Members


Apsis Members

[image] [image]

OrbitTools Track Library Documentation
Apsis Members
Apsis Class Constructors Methods Properties See Also Send Feedback

The Apsis type exposes the following members.

Constructors

 | Name | Description
Public method | Apsis | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsApogee | Returns true if this represents apogee information.
Public property | IsPerigee | Returns true if this represents perigee information.
Public property | LatitudeDeg | (Inherited from LatLon.)
Public property | LatitudeRad | (Inherited from LatLon.)
Public property | LongitudeDeg | (Inherited from LatLon.)
Public property | LongitudeRad | (Inherited from LatLon.)
Public property | RadiusKm | The distance from the coordinate system origin, in kilometers.
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the latitude/longitude data. (Inherited from LatLonTime.)

See Also

Apsis Class


Apsis Constructor

[image]

OrbitTools Track Library Documentation
Apsis Constructor
Apsis Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Apsis(
    double radLat,
    double radLon,
    double timeMpe,
    bool isApogee,
    double kmRadius
)
Visual Basic
Public Sub New ( _
    radLat As Double, _
    radLon As Double, _
    timeMpe As Double, _
    isApogee As Boolean, _
    kmRadius As Double _
)
Visual C++
public:
Apsis(
    double radLat,
    double radLon,
    double timeMpe,
    bool isApogee,
    double kmRadius
)

Parameters

radLat
Type: System..::..Double
The latitude, in radians.
radLon
Type: System..::..Double
The longitude, in radians.
timeMpe
Type: System..::..Double
Time, in minutes-past-epoch format.
isApogee
Type: System..::..Boolean
Indicates apogee or perigee information.
kmRadius
Type: System..::..Double
The distance from the coordinate system origin, in kilometers.

See Also

Apsis Class


Apsis Methods

[image] [image]

OrbitTools Track Library Documentation
Apsis Methods
Apsis Class See Also Send Feedback

The Apsis type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Apsis Class


Apsis Properties

[image] [image]

OrbitTools Track Library Documentation
Apsis Properties
Apsis Class See Also Send Feedback

The Apsis type exposes the following members.

Properties

 | Name | Description
Public property | IsApogee | Returns true if this represents apogee information.
Public property | IsPerigee | Returns true if this represents perigee information.
Public property | LatitudeDeg | (Inherited from LatLon.)
Public property | LatitudeRad | (Inherited from LatLon.)
Public property | LongitudeDeg | (Inherited from LatLon.)
Public property | LongitudeRad | (Inherited from LatLon.)
Public property | RadiusKm | The distance from the coordinate system origin, in kilometers.
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the latitude/longitude data. (Inherited from LatLonTime.)

See Also

Apsis Class


IsApogee Property

[image]

OrbitTools Track Library Documentation
Apsis..::..IsApogee Property
Apsis Class See Also Send Feedback
Returns true if this represents apogee information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsApogee { get; private set; }
Visual Basic
Public Property IsApogee As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsApogee {
    bool get ();
    private: void set (bool value);
}

See Also

Apsis Class


IsPerigee Property

[image]

OrbitTools Track Library Documentation
Apsis..::..IsPerigee Property
Apsis Class See Also Send Feedback
Returns true if this represents perigee information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsPerigee { get; }
Visual Basic
Public ReadOnly Property IsPerigee As Boolean
    Get
Visual C++
public:
property bool IsPerigee {
    bool get ();
}

See Also

Apsis Class


RadiusKm Property

[image]

OrbitTools Track Library Documentation
Apsis..::..RadiusKm Property
Apsis Class See Also Send Feedback
The distance from the coordinate system origin, in kilometers.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double RadiusKm { get; private set; }
Visual Basic
Public Property RadiusKm As Double
    Get
    Private Set
Visual C++
public:
property double RadiusKm {
    double get ();
    private: void set (double value);
}

See Also

Apsis Class


AzElTime Class

[image]

OrbitTools Track Library Documentation
AzElTime Class
Members See Also Send Feedback
Class to encapsulate satellite azimuth and elevation information at a given moment in time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public sealed class AzElTime : AzEl
Visual Basic
Public NotInheritable Class AzElTime _
    Inherits AzEl
Visual C++
public ref class AzElTime sealed : public AzEl

Inheritance Hierarchy

System..::..Object
AzEl
Zeptomoby.OrbitTools.Track..::..AzElTime

See Also

AzElTime Members


AzElTime Members

[image] [image]

OrbitTools Track Library Documentation
AzElTime Members
AzElTime Class Constructors Methods Properties See Also Send Feedback

The AzElTime type exposes the following members.

Constructors

 | Name | Description
Public method | AzElTime(AzElTime) | Copy constructor.
Public method | AzElTime(AzEl, Double) | Constructor accepting type AzEl.
Public method | AzElTime(Double, Double, Double) | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(Boolean, Boolean) | Formats a string to contain the time, azimuth, and elevation. (Overrides AzElToString(Boolean, Boolean).)

Properties

 | Name | Description
Public property | AzimuthDeg | (Inherited from AzEl.)
Public property | AzimuthRad | (Inherited from AzEl.)
Public property | ElevationDeg | (Inherited from AzEl.)
Public property | ElevationRad | (Inherited from AzEl.)
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the Azimuth and Elevation data.

See Also

AzElTime Class


AzElTime Constructor

[image] [image]

OrbitTools Track Library Documentation
AzElTime Constructor
AzElTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AzElTime(AzElTime) | Copy constructor.
Public method | AzElTime(AzEl, Double) | Constructor accepting type AzEl.
Public method | AzElTime(Double, Double, Double) | Standard constructor.

See Also

AzElTime Class
AzElTime Members


AzElTime Constructor (AzElTime)

[image]

OrbitTools Track Library Documentation
AzElTime Constructor (AzElTime)
AzElTime Class See Also Send Feedback
Copy constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime(
    AzElTime azel
)
Visual Basic
Public Sub New ( _
    azel As AzElTime _
)
Visual C++
public:
AzElTime(
    AzElTime^ azel
)

Parameters

azel
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
Source object.

See Also

AzElTime Class
AzElTime Overload


AzElTime Constructor (, Double)

[image]

OrbitTools Track Library Documentation
AzElTime Constructor (, Double)
AzElTime Class See Also Send Feedback
Constructor accepting type AzEl.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime(
    AzEl azel,
    double timeMpe
)
Visual Basic
Public Sub New ( _
    azel As AzEl, _
    timeMpe As Double _
)
Visual C++
public:
AzElTime(
    AzEl^ azel,
    double timeMpe
)

Parameters

azel
Type: AzEl
Source AzEl object.
timeMpe
Type: System..::..Double
Time, in minutes-past-epoch format.

See Also

AzElTime Class
AzElTime Overload


AzElTime Constructor (Double, Double, Double)

[image]

OrbitTools Track Library Documentation
AzElTime Constructor (Double, Double, Double)
AzElTime Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime(
    double timeMpe,
    double azimuthRad,
    double elevationRad
)
Visual Basic
Public Sub New ( _
    timeMpe As Double, _
    azimuthRad As Double, _
    elevationRad As Double _
)
Visual C++
public:
AzElTime(
    double timeMpe,
    double azimuthRad,
    double elevationRad
)

Parameters

timeMpe
Type: System..::..Double
Time, in minutes-past-epoch format.
azimuthRad
Type: System..::..Double
Azimuth, in radians.
elevationRad
Type: System..::..Double
Elevation, in radians.

See Also

AzElTime Class
AzElTime Overload


AzElTime Methods

[image] [image]

OrbitTools Track Library Documentation
AzElTime Methods
AzElTime Class See Also Send Feedback

The AzElTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(Boolean, Boolean) | Formats a string to contain the time, azimuth, and elevation. (Overrides AzElToString(Boolean, Boolean).)

See Also

AzElTime Class


ToString Method

[image] [image]

OrbitTools Track Library Documentation
AzElTime..::..ToString Method
AzElTime Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(Boolean, Boolean) | Formats a string to contain the time, azimuth, and elevation. (Overrides AzElToString(Boolean, Boolean).)

See Also

AzElTime Class
AzElTime Members


ToString Method (Boolean, Boolean)

[image]

OrbitTools Track Library Documentation
AzElTime..::..ToString Method (Boolean, Boolean)
AzElTime Class See Also Send Feedback
Formats a string to contain the time, azimuth, and elevation.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public override string ToString(
    bool showElevation,
    bool degrees
)
Visual Basic
Public Overrides Function ToString ( _
    showElevation As Boolean, _
    degrees As Boolean _
) As String
Visual C++
public:
virtual String^ ToString(
    bool showElevation,
    bool degrees
) override

Parameters

showElevation
Type: System..::..Boolean
If true, elevation information is included in the returned string.
degrees
Type: System..::..Boolean
If true, units are in degrees, else radians.

Return Value

The formatted string.

See Also

AzElTime Class
ToString Overload


AzElTime Properties

[image] [image]

OrbitTools Track Library Documentation
AzElTime Properties
AzElTime Class See Also Send Feedback

The AzElTime type exposes the following members.

Properties

 | Name | Description
Public property | AzimuthDeg | (Inherited from AzEl.)
Public property | AzimuthRad | (Inherited from AzEl.)
Public property | ElevationDeg | (Inherited from AzEl.)
Public property | ElevationRad | (Inherited from AzEl.)
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the Azimuth and Elevation data.

See Also

AzElTime Class


TimeMpe Property

[image]

OrbitTools Track Library Documentation
AzElTime..::..TimeMpe Property
AzElTime Class See Also Send Feedback
The time, in minutes-past-epoch, associated with the Azimuth and Elevation data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double TimeMpe { get; private set; }
Visual Basic
Public Property TimeMpe As Double
    Get
    Private Set
Visual C++
public:
property double TimeMpe {
    double get ();
    private: void set (double value);
}

See Also

AzElTime Class


CircularBeamProfile Class

[image]

OrbitTools Track Library Documentation
CircularBeamProfile Class
Members See Also Send Feedback
Class that describes a beam with uniform circular density.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class CircularBeamProfile : IBeamProfile
Visual Basic
Public Class CircularBeamProfile _
    Implements IBeamProfile
Visual C++
public ref class CircularBeamProfile : IBeamProfile

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..CircularBeamProfile

See Also

CircularBeamProfile Members


CircularBeamProfile Members

[image] [image]

OrbitTools Track Library Documentation
CircularBeamProfile Members
CircularBeamProfile Class Constructors Methods See Also Send Feedback

The CircularBeamProfile type exposes the following members.

Constructors

 | Name | Description
Public method | CircularBeamProfile | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProfilePoint | Returns a single profile point of a circular beam.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CircularBeamProfile Class


CircularBeamProfile Constructor

[image]

OrbitTools Track Library Documentation
CircularBeamProfile Constructor
CircularBeamProfile Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public CircularBeamProfile(
    double degBeamAngle
)
Visual Basic
Public Sub New ( _
    degBeamAngle As Double _
)
Visual C++
public:
CircularBeamProfile(
    double degBeamAngle
)

Parameters

degBeamAngle
Type: System..::..Double
The beam spread angle, in degrees.

See Also

CircularBeamProfile Class


CircularBeamProfile Methods

[image] [image]

OrbitTools Track Library Documentation
CircularBeamProfile Methods
CircularBeamProfile Class See Also Send Feedback

The CircularBeamProfile type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProfilePoint | Returns a single profile point of a circular beam.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

CircularBeamProfile Class


ProfilePoint Method

[image]

OrbitTools Track Library Documentation
CircularBeamProfile..::..ProfilePoint Method
CircularBeamProfile Class See Also Send Feedback
Returns a single profile point of a circular beam.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Point ProfilePoint(
    double radTheta,
    double kmRange
)
Visual Basic
Public Function ProfilePoint ( _
    radTheta As Double, _
    kmRange As Double _
) As Point
Visual C++
public:
virtual Point ProfilePoint(
    double radTheta,
    double kmRange
) sealed

Parameters

radTheta
Type: System..::..Double
The angle of the point, in radians, from the X axis.
kmRange
Type: System..::..Double
The distance of the X-Y plane from the source.

Return Value

The requested profile point.

Implements

IBeamProfile..::..ProfilePoint(Double, Double)

See Also

CircularBeamProfile Class


HorizonMask Class

[image]

OrbitTools Track Library Documentation
HorizonMask Class
Members See Also Send Feedback
Defines a section of the sky which is not viewable.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class HorizonMask : IMask
Visual Basic
Public Class HorizonMask _
    Implements IMask
Visual C++
public ref class HorizonMask : IMask

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..HorizonMask

See Also

HorizonMask Members


HorizonMask Members

[image] [image]

OrbitTools Track Library Documentation
HorizonMask Members
HorizonMask Class Constructors Methods Properties See Also Send Feedback

The HorizonMask type exposes the following members.

Constructors

 | Name | Description
Public method | HorizonMask | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMasked | Determines if the given coordinate is masked.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | ElevationDeg | High elevation, in degrees.
Public property | HighAzimuthDeg | High azimuth, in degrees.
Public property | LowAzimuthDeg | Low azimuth, in degrees.

See Also

HorizonMask Class


HorizonMask Constructor

[image]

OrbitTools Track Library Documentation
HorizonMask Constructor
HorizonMask Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public HorizonMask(
    double lowAzDeg,
    double highAzDeg,
    double elevationDeg
)
Visual Basic
Public Sub New ( _
    lowAzDeg As Double, _
    highAzDeg As Double, _
    elevationDeg As Double _
)
Visual C++
public:
HorizonMask(
    double lowAzDeg,
    double highAzDeg,
    double elevationDeg
)

Parameters

lowAzDeg
Type: System..::..Double
The start azimuth, in degrees.
highAzDeg
Type: System..::..Double
The end azimuth, in degrees.
elevationDeg
Type: System..::..Double
The elevation, in degrees.

See Also

HorizonMask Class


HorizonMask Methods

[image] [image]

OrbitTools Track Library Documentation
HorizonMask Methods
HorizonMask Class See Also Send Feedback

The HorizonMask type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsMasked | Determines if the given coordinate is masked.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

HorizonMask Class


IsMasked Method

[image]

OrbitTools Track Library Documentation
HorizonMask..::..IsMasked Method
HorizonMask Class See Also Send Feedback
Determines if the given coordinate is masked.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsMasked(
    AzEl azEl
)
Visual Basic
Public Function IsMasked ( _
    azEl As AzEl _
) As Boolean
Visual C++
public:
virtual bool IsMasked(
    AzEl^ azEl
) sealed

Parameters

azEl
Type: AzEl
The target coordinate.

Return Value

True if the coordinate is masked, else false.

Implements

IMask..::..IsMasked(AzEl)

See Also

HorizonMask Class


HorizonMask Properties

[image] [image]

OrbitTools Track Library Documentation
HorizonMask Properties
HorizonMask Class See Also Send Feedback

The HorizonMask type exposes the following members.

Properties

 | Name | Description
Public property | ElevationDeg | High elevation, in degrees.
Public property | HighAzimuthDeg | High azimuth, in degrees.
Public property | LowAzimuthDeg | Low azimuth, in degrees.

See Also

HorizonMask Class


ElevationDeg Property

[image]

OrbitTools Track Library Documentation
HorizonMask..::..ElevationDeg Property
HorizonMask Class See Also Send Feedback
High elevation, in degrees.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double ElevationDeg { get; private set; }
Visual Basic
Public Property ElevationDeg As Double
    Get
    Private Set
Visual C++
public:
property double ElevationDeg {
    double get ();
    private: void set (double value);
}

See Also

HorizonMask Class


HighAzimuthDeg Property

[image]

OrbitTools Track Library Documentation
HorizonMask..::..HighAzimuthDeg Property
HorizonMask Class See Also Send Feedback
High azimuth, in degrees.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double HighAzimuthDeg { get; private set; }
Visual Basic
Public Property HighAzimuthDeg As Double
    Get
    Private Set
Visual C++
public:
property double HighAzimuthDeg {
    double get ();
    private: void set (double value);
}

See Also

HorizonMask Class


LowAzimuthDeg Property

[image]

OrbitTools Track Library Documentation
HorizonMask..::..LowAzimuthDeg Property
HorizonMask Class See Also Send Feedback
Low azimuth, in degrees.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double LowAzimuthDeg { get; private set; }
Visual Basic
Public Property LowAzimuthDeg As Double
    Get
    Private Set
Visual C++
public:
property double LowAzimuthDeg {
    double get ();
    private: void set (double value);
}

See Also

HorizonMask Class


IBeamProfile Interface

[image]

OrbitTools Track Library Documentation
IBeamProfile Interface
Members See Also Send Feedback
Interface that describes a beam of arbitrary cross-sectional shape.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public interface IBeamProfile
Visual Basic
Public Interface IBeamProfile
Visual C++
public interface class IBeamProfile

See Also

IBeamProfile Members


IBeamProfile Members

[image] [image]

OrbitTools Track Library Documentation
IBeamProfile Members
IBeamProfile Interface Methods See Also Send Feedback

The IBeamProfile type exposes the following members.

Methods

 | Name | Description
Public method | ProfilePoint | Returns a single point of a cross section of an arbitrarily-shaped beam projected on an X-Y plane.

See Also

IBeamProfile Interface


IBeamProfile Methods

[image] [image]

OrbitTools Track Library Documentation
IBeamProfile Methods
IBeamProfile Interface See Also Send Feedback

The IBeamProfile type exposes the following members.

Methods

 | Name | Description
Public method | ProfilePoint | Returns a single point of a cross section of an arbitrarily-shaped beam projected on an X-Y plane.

See Also

IBeamProfile Interface


ProfilePoint Method

[image]

OrbitTools Track Library Documentation
IBeamProfile..::..ProfilePoint Method
IBeamProfile Interface See Also Send Feedback
Returns a single point of a cross section of an arbitrarily-shaped beam projected on an X-Y plane.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
Point ProfilePoint(
    double radTheta,
    double kmRange
)
Visual Basic
Function ProfilePoint ( _
    radTheta As Double, _
    kmRange As Double _
) As Point
Visual C++
Point ProfilePoint(
    double radTheta,
    double kmRange
)

Parameters

radTheta
Type: System..::..Double
The radius angle, measured from the positive X-axis, to the cross section point, in radians.
kmRange
Type: System..::..Double
The distance from the beam source to the X-Y plane, in kilometers.

Return Value

The point on the X-Y plane where the beam intersects.

See Also

IBeamProfile Interface


IMask Interface

[image]

OrbitTools Track Library Documentation
IMask Interface
Members See Also Send Feedback
Interface used to define mask parameters.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public interface IMask
Visual Basic
Public Interface IMask
Visual C++
public interface class IMask

See Also

IMask Members


IMask Members

[image] [image]

OrbitTools Track Library Documentation
IMask Members
IMask Interface Methods See Also Send Feedback

The IMask type exposes the following members.

Methods

 | Name | Description
Public method | IsMasked | Determines if the given coordinate is masked.

See Also

IMask Interface


IMask Methods

[image] [image]

OrbitTools Track Library Documentation
IMask Methods
IMask Interface See Also Send Feedback

The IMask type exposes the following members.

Methods

 | Name | Description
Public method | IsMasked | Determines if the given coordinate is masked.

See Also

IMask Interface


IsMasked Method

[image]

OrbitTools Track Library Documentation
IMask..::..IsMasked Method
IMask Interface See Also Send Feedback
Determines if the given coordinate is masked.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
bool IsMasked(
    AzEl azEl
)
Visual Basic
Function IsMasked ( _
    azEl As AzEl _
) As Boolean
Visual C++
bool IsMasked(
    AzEl^ azEl
)

Parameters

azEl
Type: AzEl
The target coordinate.

Return Value

True if the coordinate is masked, else false.

See Also

IMask Interface


LatLonTime Class

[image]

OrbitTools Track Library Documentation
LatLonTime Class
Members See Also Send Feedback
Class to encapsulate latitude/longitude pair and a time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class LatLonTime : LatLon
Visual Basic
Public Class LatLonTime _
    Inherits LatLon
Visual C++
public ref class LatLonTime : public LatLon

Inheritance Hierarchy

System..::..Object
LatLon
Zeptomoby.OrbitTools.Track..::..LatLonTime
Zeptomoby.OrbitTools.Track..::..Apsis
Zeptomoby.OrbitTools.Track..::..Node

See Also

LatLonTime Members


LatLonTime Members

[image] [image]

OrbitTools Track Library Documentation
LatLonTime Members
LatLonTime Class Constructors Methods Properties See Also Send Feedback

The LatLonTime type exposes the following members.

Constructors

 | Name | Description
Public method | LatLonTime | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | LatitudeDeg | (Inherited from LatLon.)
Public property | LatitudeRad | (Inherited from LatLon.)
Public property | LongitudeDeg | (Inherited from LatLon.)
Public property | LongitudeRad | (Inherited from LatLon.)
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the latitude/longitude data.

See Also

LatLonTime Class


LatLonTime Constructor

[image]

OrbitTools Track Library Documentation
LatLonTime Constructor
LatLonTime Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public LatLonTime(
    double radLat,
    double radLon,
    double timeMpe
)
Visual Basic
Public Sub New ( _
    radLat As Double, _
    radLon As Double, _
    timeMpe As Double _
)
Visual C++
public:
LatLonTime(
    double radLat,
    double radLon,
    double timeMpe
)

Parameters

radLat
Type: System..::..Double
The latitude, in radians.
radLon
Type: System..::..Double
The longitude, in radians.
timeMpe
Type: System..::..Double
Time, in minutes-past-epoch format.

See Also

LatLonTime Class


LatLonTime Methods

[image] [image]

OrbitTools Track Library Documentation
LatLonTime Methods
LatLonTime Class See Also Send Feedback

The LatLonTime type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

LatLonTime Class


LatLonTime Properties

[image] [image]

OrbitTools Track Library Documentation
LatLonTime Properties
LatLonTime Class See Also Send Feedback

The LatLonTime type exposes the following members.

Properties

 | Name | Description
Public property | LatitudeDeg | (Inherited from LatLon.)
Public property | LatitudeRad | (Inherited from LatLon.)
Public property | LongitudeDeg | (Inherited from LatLon.)
Public property | LongitudeRad | (Inherited from LatLon.)
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the latitude/longitude data.

See Also

LatLonTime Class


TimeMpe Property

[image]

OrbitTools Track Library Documentation
LatLonTime..::..TimeMpe Property
LatLonTime Class See Also Send Feedback
The time, in minutes-past-epoch, associated with the latitude/longitude data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double TimeMpe { get; private set; }
Visual Basic
Public Property TimeMpe As Double
    Get
    Private Set
Visual C++
public:
property double TimeMpe {
    double get ();
    private: void set (double value);
}

See Also

LatLonTime Class


Node Class

[image]

OrbitTools Track Library Documentation
Node Class
Members See Also Send Feedback
Class to encapsulate data associated with an orbital node.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class Node : LatLonTime
Visual Basic
Public Class Node _
    Inherits LatLonTime
Visual C++
public ref class Node : public LatLonTime

Inheritance Hierarchy

System..::..Object
LatLon
Zeptomoby.OrbitTools.Track..::..LatLonTime
Zeptomoby.OrbitTools.Track..::..Node

See Also

Node Members


Node Members

[image] [image]

OrbitTools Track Library Documentation
Node Members
Node Class Constructors Methods Properties See Also Send Feedback

The Node type exposes the following members.

Constructors

 | Name | Description
Public method | Node | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

Properties

 | Name | Description
Public property | IsAscending | Returns true if this represents ascending node information.
Public property | IsDescending | Returns true if this represents descending node information.
Public property | LatitudeDeg | (Inherited from LatLon.)
Public property | LatitudeRad | (Inherited from LatLon.)
Public property | LongitudeDeg | (Inherited from LatLon.)
Public property | LongitudeRad | (Inherited from LatLon.)
Public property | RadiusKm | The distance from the coordinate system origin, in kilometers.
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the latitude/longitude data. (Inherited from LatLonTime.)

See Also

Node Class


Node Constructor

[image]

OrbitTools Track Library Documentation
Node Constructor
Node Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Node(
    double radLat,
    double radLon,
    double timeMpe,
    bool isAscending,
    double kmRadius
)
Visual Basic
Public Sub New ( _
    radLat As Double, _
    radLon As Double, _
    timeMpe As Double, _
    isAscending As Boolean, _
    kmRadius As Double _
)
Visual C++
public:
Node(
    double radLat,
    double radLon,
    double timeMpe,
    bool isAscending,
    double kmRadius
)

Parameters

radLat
Type: System..::..Double
The latitude, in radians.
radLon
Type: System..::..Double
The longitude, in radians.
timeMpe
Type: System..::..Double
Time, in minutes-past-epoch format.
isAscending
Type: System..::..Boolean
Indicates ascending or descending node.
kmRadius
Type: System..::..Double
The distance from the coordinate system origin, in kilometers.

See Also

Node Class


Node Methods

[image] [image]

OrbitTools Track Library Documentation
Node Methods
Node Class See Also Send Feedback

The Node type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)

See Also

Node Class


Node Properties

[image] [image]

OrbitTools Track Library Documentation
Node Properties
Node Class See Also Send Feedback

The Node type exposes the following members.

Properties

 | Name | Description
Public property | IsAscending | Returns true if this represents ascending node information.
Public property | IsDescending | Returns true if this represents descending node information.
Public property | LatitudeDeg | (Inherited from LatLon.)
Public property | LatitudeRad | (Inherited from LatLon.)
Public property | LongitudeDeg | (Inherited from LatLon.)
Public property | LongitudeRad | (Inherited from LatLon.)
Public property | RadiusKm | The distance from the coordinate system origin, in kilometers.
Public property | TimeMpe | The time, in minutes-past-epoch, associated with the latitude/longitude data. (Inherited from LatLonTime.)

See Also

Node Class


IsAscending Property

[image]

OrbitTools Track Library Documentation
Node..::..IsAscending Property
Node Class See Also Send Feedback
Returns true if this represents ascending node information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsAscending { get; private set; }
Visual Basic
Public Property IsAscending As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsAscending {
    bool get ();
    private: void set (bool value);
}

See Also

Node Class


IsDescending Property

[image]

OrbitTools Track Library Documentation
Node..::..IsDescending Property
Node Class See Also Send Feedback
Returns true if this represents descending node information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsDescending { get; }
Visual Basic
Public ReadOnly Property IsDescending As Boolean
    Get
Visual C++
public:
property bool IsDescending {
    bool get ();
}

See Also

Node Class


RadiusKm Property

[image]

OrbitTools Track Library Documentation
Node..::..RadiusKm Property
Node Class See Also Send Feedback
The distance from the coordinate system origin, in kilometers.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double RadiusKm { get; private set; }
Visual Basic
Public Property RadiusKm As Double
    Get
    Private Set
Visual C++
public:
property double RadiusKm {
    double get ();
    private: void set (double value);
}

See Also

Node Class


PassData Class

[image]

OrbitTools Track Library Documentation
PassData Class
Members See Also Send Feedback
Class to encapsulate satellite AOS (rise) data, LOS (set) data, and MAX (maximum elevation above horizon) data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public sealed class PassData
Visual Basic
Public NotInheritable Class PassData
Visual C++
public ref class PassData sealed

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..PassData

See Also

PassData Members


PassData Members

[image] [image]

OrbitTools Track Library Documentation
PassData Members
PassData Class Constructors Methods Properties See Also Send Feedback

The PassData type exposes the following members.

Constructors

 | Name | Description
Public method | PassData(Double) | Constructor for decayed orbits.
Public method | PassData(AzElTime, AzElTime) | Create an object with AOS and LOS information.
Public method | PassData(AzElTime, AzElTime, AzElTime) | Create an object with AOS, LOS, and MAX information.

Methods

 | Name | Description
Public method | Availability | Calculates the availability of the satellite for the pass.
Public method | CalcPassSegments(Station, Satellite, DateTime, DateTime) | Calculates the set of pass segments the satellite pass.
Public method | CalcPassSegments(Station, Satellite, Double, Double) | Calculates the set of pass segments for the satellite pass.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string containing minutes-past-epoch-style AOS/MAX/LOS data. (Overrides Object..::..ToString()()()().)
Public method | ToString(IOrbit, TimeZoneInfo, String, String) | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the specified time zone.
Public method | ToStringLocal | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the current local time.
Public method | ToStringUtc | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in UTC.

Properties

 | Name | Description
Public property | Aos | Acquisition Of Signal data.
Public property | DecayMpe | The minutes-past-epoch time that the satellite orbit decayed (or null if not decayed).
Public property | IsDecayed | Returns true if the satellite orbit has decayed.
Public property | IsValidAos | Indicates if the AOS data is specified.
Public property | IsValidLos | Indicates if the LOS data is specified.
Public property | IsValidMax | Indicates if the MAX data is specified.
Public property | Los | Loss of Signal data.
Public property | Max | Maximum elevation data.
Public property | Segments | The list of segments that comprise the overall pass.

See Also

PassData Class


PassData Constructor

[image] [image]

OrbitTools Track Library Documentation
PassData Constructor
PassData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PassData(Double) | Constructor for decayed orbits.
Public method | PassData(AzElTime, AzElTime) | Create an object with AOS and LOS information.
Public method | PassData(AzElTime, AzElTime, AzElTime) | Create an object with AOS, LOS, and MAX information.

See Also

PassData Class
PassData Members


PassData Constructor (Double)

[image]

OrbitTools Track Library Documentation
PassData Constructor (Double)
PassData Class See Also Send Feedback
Constructor for decayed orbits.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PassData(
    double decayMpe
)
Visual Basic
Public Sub New ( _
    decayMpe As Double _
)
Visual C++
public:
PassData(
    double decayMpe
)

Parameters

decayMpe
Type: System..::..Double
The time, in minutes-past-epoch, that the satellite orbit decayed.

See Also

PassData Class
PassData Overload


PassData Constructor (AzElTime, AzElTime)

[image]

OrbitTools Track Library Documentation
PassData Constructor (AzElTime, AzElTime)
PassData Class See Also Send Feedback
Create an object with AOS and LOS information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PassData(
    AzElTime aos,
    AzElTime los
)
Visual Basic
Public Sub New ( _
    aos As AzElTime, _
    los As AzElTime _
)
Visual C++
public:
PassData(
    AzElTime^ aos,
    AzElTime^ los
)

Parameters

aos
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
Acquisition of signal time.
los
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
Loss of signal time.

See Also

PassData Class
PassData Overload


PassData Constructor (AzElTime, AzElTime, AzElTime)

[image]

OrbitTools Track Library Documentation
PassData Constructor (AzElTime, AzElTime, AzElTime)
PassData Class See Also Send Feedback
Create an object with AOS, LOS, and MAX information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PassData(
    AzElTime aos,
    AzElTime los,
    AzElTime max
)
Visual Basic
Public Sub New ( _
    aos As AzElTime, _
    los As AzElTime, _
    max As AzElTime _
)
Visual C++
public:
PassData(
    AzElTime^ aos,
    AzElTime^ los,
    AzElTime^ max
)

Parameters

aos
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
Acquisition of signal time.
los
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
Loss of signal time.
max
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
Time of maximum elevation.

See Also

PassData Class
PassData Overload


PassData Methods

[image] [image]

OrbitTools Track Library Documentation
PassData Methods
PassData Class See Also Send Feedback

The PassData type exposes the following members.

Methods

 | Name | Description
Public method | Availability | Calculates the availability of the satellite for the pass.
Public method | CalcPassSegments(Station, Satellite, DateTime, DateTime) | Calculates the set of pass segments the satellite pass.
Public method | CalcPassSegments(Station, Satellite, Double, Double) | Calculates the set of pass segments for the satellite pass.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string containing minutes-past-epoch-style AOS/MAX/LOS data. (Overrides Object..::..ToString()()()().)
Public method | ToString(IOrbit, TimeZoneInfo, String, String) | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the specified time zone.
Public method | ToStringLocal | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the current local time.
Public method | ToStringUtc | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in UTC.

See Also

PassData Class


Availability Method

[image]

OrbitTools Track Library Documentation
PassData..::..Availability Method
PassData Class See Also Send Feedback
Calculates the availability of the satellite for the pass.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double Availability()
Visual Basic
Public Function Availability As Double
Visual C++
public:
double Availability()

Return Value

The satellite availability, in percent.

See Also

PassData Class


CalcPassSegments Method

[image] [image]

OrbitTools Track Library Documentation
PassData..::..CalcPassSegments Method
PassData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | CalcPassSegments(Station, Satellite, DateTime, DateTime) | Calculates the set of pass segments the satellite pass.
Public method | CalcPassSegments(Station, Satellite, Double, Double) | Calculates the set of pass segments for the satellite pass.

See Also

PassData Class
PassData Members


CalcPassSegments Method (Station, , DateTime, DateTime)

[image]

OrbitTools Track Library Documentation
PassData..::..CalcPassSegments Method (Station, , DateTime, DateTime)
PassData Class See Also Send Feedback
Calculates the set of pass segments the satellite pass.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void CalcPassSegments(
    Station station,
    Satellite sat,
    DateTime t1,
    DateTime t2
)
Visual Basic
Public Sub CalcPassSegments ( _
    station As Station, _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime _
)
Visual C++
public:
void CalcPassSegments(
    Station^ station,
    Satellite^ sat,
    DateTime t1,
    DateTime t2
)

Parameters

station
Type: Zeptomoby.OrbitTools.Track..::..Station
The Earth station.
sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time; used only if no valid AOS is defined.
t2
Type: System..::..DateTime
The stop time; used only if no valid LOS is defined.

See Also

PassData Class
CalcPassSegments Overload


CalcPassSegments Method (Station, , Double, Double)

[image]

OrbitTools Track Library Documentation
PassData..::..CalcPassSegments Method (Station, , Double, Double)
PassData Class See Also Send Feedback
Calculates the set of pass segments for the satellite pass.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void CalcPassSegments(
    Station station,
    Satellite sat,
    double t1,
    double t2
)
Visual Basic
Public Sub CalcPassSegments ( _
    station As Station, _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double _
)
Visual C++
public:
void CalcPassSegments(
    Station^ station,
    Satellite^ sat,
    double t1,
    double t2
)

Parameters

station
Type: Zeptomoby.OrbitTools.Track..::..Station
The Earth station.
sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time; used only if no valid AOS is defined.
t2
Type: System..::..Double
The stop time; used only if no valid LOS is defined.

See Also

PassData Class
CalcPassSegments Overload


ToString Method

[image] [image]

OrbitTools Track Library Documentation
PassData..::..ToString Method
PassData Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a string containing minutes-past-epoch-style AOS/MAX/LOS data. (Overrides Object..::..ToString()()()().)
Public method | ToString(IOrbit, TimeZoneInfo, String, String) | Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the specified time zone.

See Also

PassData Class
PassData Members


ToString Method

[image]

OrbitTools Track Library Documentation
PassData..::..ToString Method
PassData Class See Also Send Feedback
Returns a string containing minutes-past-epoch-style AOS/MAX/LOS data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

The formatted string.

See Also

PassData Class
ToString Overload


ToString Method (, TimeZoneInfo, String, String)

[image]

OrbitTools Track Library Documentation
PassData..::..ToString Method (, TimeZoneInfo, String, String)
PassData Class See Also Send Feedback
Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the specified time zone.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public string ToString(
    IOrbit orbit,
    TimeZoneInfo tzInfo,
    string zoneName,
    string zoneNameDst
)
Visual Basic
Public Function ToString ( _
    orbit As IOrbit, _
    tzInfo As TimeZoneInfo, _
    zoneName As String, _
    zoneNameDst As String _
) As String
Visual C++
public:
String^ ToString(
    IOrbit^ orbit,
    TimeZoneInfo^ tzInfo,
    String^ zoneName,
    String^ zoneNameDst
)

Parameters

orbit
Type: IOrbit
The satellite orbit.
tzInfo
Type: System..::..TimeZoneInfo
The target time zone information.
zoneName
Type: System..::..String
The abbreviated name of the time zone during standard time (i.e., "LST").
zoneNameDst
Type: System..::..String
The abbreviated name of the time zone during daylight savings time (i.e., "LDT").

Return Value

The formatted string.

See Also

PassData Class
ToString Overload


ToStringLocal Method

[image]

OrbitTools Track Library Documentation
PassData..::..ToStringLocal Method
PassData Class See Also Send Feedback
Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in the current local time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public string ToStringLocal(
    IOrbit orbit,
    string zoneName,
    string zoneNameDst
)
Visual Basic
Public Function ToStringLocal ( _
    orbit As IOrbit, _
    zoneName As String, _
    zoneNameDst As String _
) As String
Visual C++
public:
String^ ToStringLocal(
    IOrbit^ orbit,
    String^ zoneName,
    String^ zoneNameDst
)

Parameters

orbit
Type: IOrbit

[Missing <param name="orbit"/> documentation for "M:Zeptomoby.OrbitTools.Track.PassData.ToStringLocal(Zeptomoby.OrbitTools.IOrbit,System.String,System.String)"]

zoneName
Type: System..::..String
The abbreviated name of the time zone during standard time (i.e., "LST").
zoneNameDst
Type: System..::..String
The abbreviated name of the time zone during daylight savings time (i.e., "LDT").

Return Value

The formatted string.

See Also

PassData Class


ToStringUtc Method

[image]

OrbitTools Track Library Documentation
PassData..::..ToStringUtc Method
PassData Class See Also Send Feedback
Returns a string containing calendar date-style AOS/MAX/LOS data with the times given in UTC.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public string ToStringUtc(
    IOrbit orbit
)
Visual Basic
Public Function ToStringUtc ( _
    orbit As IOrbit _
) As String
Visual C++
public:
String^ ToStringUtc(
    IOrbit^ orbit
)

Parameters

orbit
Type: IOrbit
The satellite orbit.

Return Value

The formatted string.

See Also

PassData Class


PassData Properties

[image] [image]

OrbitTools Track Library Documentation
PassData Properties
PassData Class See Also Send Feedback

The PassData type exposes the following members.

Properties

 | Name | Description
Public property | Aos | Acquisition Of Signal data.
Public property | DecayMpe | The minutes-past-epoch time that the satellite orbit decayed (or null if not decayed).
Public property | IsDecayed | Returns true if the satellite orbit has decayed.
Public property | IsValidAos | Indicates if the AOS data is specified.
Public property | IsValidLos | Indicates if the LOS data is specified.
Public property | IsValidMax | Indicates if the MAX data is specified.
Public property | Los | Loss of Signal data.
Public property | Max | Maximum elevation data.
Public property | Segments | The list of segments that comprise the overall pass.

See Also

PassData Class


Aos Property

[image]

OrbitTools Track Library Documentation
PassData..::..Aos Property
PassData Class See Also Send Feedback
Acquisition Of Signal data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime Aos { get; set; }
Visual Basic
Public Property Aos As AzElTime
    Get
    Set
Visual C++
public:
property AzElTime^ Aos {
    AzElTime^ get ();
    void set (AzElTime^ value);
}

See Also

PassData Class


DecayMpe Property

[image]

OrbitTools Track Library Documentation
PassData..::..DecayMpe Property
PassData Class See Also Send Feedback
The minutes-past-epoch time that the satellite orbit decayed (or null if not decayed).

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Nullable<double> DecayMpe { get; private set; }
Visual Basic
Public Property DecayMpe As Nullable(Of Double)
    Get
    Private Set
Visual C++
public:
property Nullable<double> DecayMpe {
    Nullable<double> get ();
    private: void set (Nullable<double> value);
}

See Also

PassData Class


IsDecayed Property

[image]

OrbitTools Track Library Documentation
PassData..::..IsDecayed Property
PassData Class See Also Send Feedback
Returns true if the satellite orbit has decayed.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsDecayed { get; }
Visual Basic
Public ReadOnly Property IsDecayed As Boolean
    Get
Visual C++
public:
property bool IsDecayed {
    bool get ();
}

See Also

PassData Class


IsValidAos Property

[image]

OrbitTools Track Library Documentation
PassData..::..IsValidAos Property
PassData Class See Also Send Feedback
Indicates if the AOS data is specified.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsValidAos { get; }
Visual Basic
Public ReadOnly Property IsValidAos As Boolean
    Get
Visual C++
public:
property bool IsValidAos {
    bool get ();
}

See Also

PassData Class


IsValidLos Property

[image]

OrbitTools Track Library Documentation
PassData..::..IsValidLos Property
PassData Class See Also Send Feedback
Indicates if the LOS data is specified.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsValidLos { get; }
Visual Basic
Public ReadOnly Property IsValidLos As Boolean
    Get
Visual C++
public:
property bool IsValidLos {
    bool get ();
}

See Also

PassData Class


IsValidMax Property

[image]

OrbitTools Track Library Documentation
PassData..::..IsValidMax Property
PassData Class See Also Send Feedback
Indicates if the MAX data is specified.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsValidMax { get; }
Visual Basic
Public ReadOnly Property IsValidMax As Boolean
    Get
Visual C++
public:
property bool IsValidMax {
    bool get ();
}

See Also

PassData Class


Los Property

[image]

OrbitTools Track Library Documentation
PassData..::..Los Property
PassData Class See Also Send Feedback
Loss of Signal data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime Los { get; set; }
Visual Basic
Public Property Los As AzElTime
    Get
    Set
Visual C++
public:
property AzElTime^ Los {
    AzElTime^ get ();
    void set (AzElTime^ value);
}

See Also

PassData Class


Max Property

[image]

OrbitTools Track Library Documentation
PassData..::..Max Property
PassData Class See Also Send Feedback
Maximum elevation data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime Max { get; set; }
Visual Basic
Public Property Max As AzElTime
    Get
    Set
Visual C++
public:
property AzElTime^ Max {
    AzElTime^ get ();
    void set (AzElTime^ value);
}

See Also

PassData Class


Segments Property

[image]

OrbitTools Track Library Documentation
PassData..::..Segments Property
PassData Class See Also Send Feedback
The list of segments that comprise the overall pass.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public List<PassSegment> Segments { get; private set; }
Visual Basic
Public Property Segments As List(Of PassSegment)
    Get
    Private Set
Visual C++
public:
property List<PassSegment^>^ Segments {
    List<PassSegment^>^ get ();
    private: void set (List<PassSegment^>^ value);
}

See Also

PassData Class


PassSegment Class

[image]

OrbitTools Track Library Documentation
PassSegment Class
Members See Also Send Feedback
Defines a segment of a satellite pass.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class PassSegment
Visual Basic
Public Class PassSegment
Visual C++
public ref class PassSegment

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..PassSegment

See Also

PassSegment Members


PassSegment Members

[image] [image]

OrbitTools Track Library Documentation
PassSegment Members
PassSegment Class Constructors Methods Properties See Also Send Feedback

The PassSegment type exposes the following members.

Constructors

 | Name | Description
Public method | PassSegment | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(Boolean, Boolean) | Returns a string representation of the object's state.

Properties

 | Name | Description
Public property | DurationMin | Segment time duration, in minutes.
Public property | IsVisible | Returns true if the satellite is visible during the segment.
Public property | Start | Segment start information.
Public property | Stop | Segment stop information.

See Also

PassSegment Class


PassSegment Constructor

[image]

OrbitTools Track Library Documentation
PassSegment Constructor
PassSegment Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PassSegment(
    AzElTime start,
    AzElTime stop,
    bool isVisible
)
Visual Basic
Public Sub New ( _
    start As AzElTime, _
    stop As AzElTime, _
    isVisible As Boolean _
)
Visual C++
public:
PassSegment(
    AzElTime^ start,
    AzElTime^ stop,
    bool isVisible
)

Parameters

start
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
The segment start time, in minutes-past-epoch.
stop
Type: Zeptomoby.OrbitTools.Track..::..AzElTime
The segment stop time, in minutes-past-epoch.
isVisible
Type: System..::..Boolean
If true, indicates the satellite is visible during the segment.

See Also

PassSegment Class


PassSegment Methods

[image] [image]

OrbitTools Track Library Documentation
PassSegment Methods
PassSegment Class See Also Send Feedback

The PassSegment type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(Boolean, Boolean) | Returns a string representation of the object's state.

See Also

PassSegment Class


ToString Method

[image] [image]

OrbitTools Track Library Documentation
PassSegment..::..ToString Method
PassSegment Class See Also Send Feedback

Overload List

 | Name | Description
Public method | ToString()()()() | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToString(Boolean, Boolean) | Returns a string representation of the object's state.

See Also

PassSegment Class
PassSegment Members


ToString Method (Boolean, Boolean)

[image]

OrbitTools Track Library Documentation
PassSegment..::..ToString Method (Boolean, Boolean)
PassSegment Class See Also Send Feedback
Returns a string representation of the object's state.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public virtual string ToString(
    bool showElevation,
    bool degrees
)
Visual Basic
Public Overridable Function ToString ( _
    showElevation As Boolean, _
    degrees As Boolean _
) As String
Visual C++
public:
virtual String^ ToString(
    bool showElevation,
    bool degrees
)

Parameters

showElevation
Type: System..::..Boolean

[Missing <param name="showElevation"/> documentation for "M:Zeptomoby.OrbitTools.Track.PassSegment.ToString(System.Boolean,System.Boolean)"]

degrees
Type: System..::..Boolean

[Missing <param name="degrees"/> documentation for "M:Zeptomoby.OrbitTools.Track.PassSegment.ToString(System.Boolean,System.Boolean)"]

Return Value

The formatted string.

See Also

PassSegment Class
ToString Overload


PassSegment Properties

[image] [image]

OrbitTools Track Library Documentation
PassSegment Properties
PassSegment Class See Also Send Feedback

The PassSegment type exposes the following members.

Properties

 | Name | Description
Public property | DurationMin | Segment time duration, in minutes.
Public property | IsVisible | Returns true if the satellite is visible during the segment.
Public property | Start | Segment start information.
Public property | Stop | Segment stop information.

See Also

PassSegment Class


DurationMin Property

[image]

OrbitTools Track Library Documentation
PassSegment..::..DurationMin Property
PassSegment Class See Also Send Feedback
Segment time duration, in minutes.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public double DurationMin { get; }
Visual Basic
Public ReadOnly Property DurationMin As Double
    Get
Visual C++
public:
property double DurationMin {
    double get ();
}

See Also

PassSegment Class


IsVisible Property

[image]

OrbitTools Track Library Documentation
PassSegment..::..IsVisible Property
PassSegment Class See Also Send Feedback
Returns true if the satellite is visible during the segment.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool IsVisible { get; private set; }
Visual Basic
Public Property IsVisible As Boolean
    Get
    Private Set
Visual C++
public:
property bool IsVisible {
    bool get ();
    private: void set (bool value);
}

See Also

PassSegment Class


Start Property

[image]

OrbitTools Track Library Documentation
PassSegment..::..Start Property
PassSegment Class See Also Send Feedback
Segment start information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime Start { get; private set; }
Visual Basic
Public Property Start As AzElTime
    Get
    Private Set
Visual C++
public:
property AzElTime^ Start {
    AzElTime^ get ();
    private: void set (AzElTime^ value);
}

See Also

PassSegment Class


Stop Property

[image]

OrbitTools Track Library Documentation
PassSegment..::..Stop Property
PassSegment Class See Also Send Feedback
Segment stop information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public AzElTime Stop { get; private set; }
Visual Basic
Public Property Stop As AzElTime
    Get
    Private Set
Visual C++
public:
property AzElTime^ Stop {
    AzElTime^ get ();
    private: void set (AzElTime^ value);
}

See Also

PassSegment Class


PeriodInfo(T) Class

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Class to encapsulate a time period and associated "content", which is a list of type T. The period start and stop times are rounded to the nearest second.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public sealed class PeriodInfo<T>
Visual Basic
Public NotInheritable Class PeriodInfo(Of T)
Visual C++
generic<typename T>
public ref class PeriodInfo sealed

Type Parameters

T
Specifies the type of the Period Info "content".

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..PeriodInfo<(Of <(<'T>)>)>

See Also

PeriodInfo<(Of <(<'T>)>)> Members


PeriodInfo(T) Members

[image] [image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Members
PeriodInfo<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The PeriodInfo<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | PeriodInfo<(Of <(<'T>)>)>(DateTime, DateTime) | Standard constructor.
Public method | PeriodInfo<(Of <(<'T>)>)>(DateTime, DateTime, IEnumerable<(Of <<'(T>)>>)) | Constructor accepting content items.
Public method | PeriodInfo<(Of <(<'T>)>)>(DateTime, DateTime, T) | Constructor accepting content item.

Methods

 | Name | Description
Public method | AddContent(IEnumerable<(Of <<'(T>)>>)) | Adds items to the time period's content list.
Public method | AddContent(T) | Adds an item to the time period's content list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Overlaps | Returns true if the given period overlaps in time.
Public method | ToString | Shows the start, stop times and the period overlap count. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | Content | The content list associated with the time period.
Public property | OverlapCount | The period overlap count.
Public property | Start | The starting time of the period.
Public property | Stop | The ending time of the period.

See Also

PeriodInfo<(Of <(<'T>)>)> Class


PeriodInfo(T) Constructor

[image] [image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Constructor
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PeriodInfo<(Of <(<'T>)>)>(DateTime, DateTime) | Standard constructor.
Public method | PeriodInfo<(Of <(<'T>)>)>(DateTime, DateTime, IEnumerable<(Of <<'(T>)>>)) | Constructor accepting content items.
Public method | PeriodInfo<(Of <(<'T>)>)>(DateTime, DateTime, T) | Constructor accepting content item.

See Also

PeriodInfo<(Of <(<'T>)>)> Class
PeriodInfo<(Of <(<'T>)>)> Members


PeriodInfo(T) Constructor (DateTime, DateTime)

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Constructor (DateTime, DateTime)
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PeriodInfo(
    DateTime start,
    DateTime stop
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    stop As DateTime _
)
Visual C++
public:
PeriodInfo(
    DateTime start,
    DateTime stop
)

Parameters

start
Type: System..::..DateTime

[Missing <param name="start"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime)"]

stop
Type: System..::..DateTime

[Missing <param name="stop"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime)"]

See Also

PeriodInfo<(Of <(<'T>)>)> Class
PeriodInfo<(Of <(<'T>)>)> Overload


PeriodInfo(T) Constructor (DateTime, DateTime, IEnumerable(T))

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Constructor (DateTime, DateTime, IEnumerable<(Of <(<'T>)>)>)
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Constructor accepting content items.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PeriodInfo(
    DateTime start,
    DateTime stop,
    IEnumerable<T> contents
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    stop As DateTime, _
    contents As IEnumerable(Of T) _
)
Visual C++
public:
PeriodInfo(
    DateTime start,
    DateTime stop,
    IEnumerable<T>^ contents
)

Parameters

start
Type: System..::..DateTime

[Missing <param name="start"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime,System.Collections.Generic.IEnumerable{`0})"]

stop
Type: System..::..DateTime

[Missing <param name="stop"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime,System.Collections.Generic.IEnumerable{`0})"]

contents
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' T >)>)>

[Missing <param name="contents"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime,System.Collections.Generic.IEnumerable{`0})"]

See Also

PeriodInfo<(Of <(<'T>)>)> Class
PeriodInfo<(Of <(<'T>)>)> Overload


PeriodInfo(T) Constructor (DateTime, DateTime, T)

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Constructor (DateTime, DateTime, T)
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Constructor accepting content item.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public PeriodInfo(
    DateTime start,
    DateTime stop,
    T content
)
Visual Basic
Public Sub New ( _
    start As DateTime, _
    stop As DateTime, _
    content As T _
)
Visual C++
public:
PeriodInfo(
    DateTime start,
    DateTime stop,
    T content
)

Parameters

start
Type: System..::..DateTime

[Missing <param name="start"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime,`0)"]

stop
Type: System..::..DateTime

[Missing <param name="stop"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime,`0)"]

content
Type: T

[Missing <param name="content"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.#ctor(System.DateTime,System.DateTime,`0)"]

See Also

PeriodInfo<(Of <(<'T>)>)> Class
PeriodInfo<(Of <(<'T>)>)> Overload


PeriodInfo(T) Methods

[image] [image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Methods
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback

The PeriodInfo<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddContent(IEnumerable<(Of <<'(T>)>>)) | Adds items to the time period's content list.
Public method | AddContent(T) | Adds an item to the time period's content list.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Overlaps | Returns true if the given period overlaps in time.
Public method | ToString | Shows the start, stop times and the period overlap count. (Overrides Object..::..ToString()()()().)

See Also

PeriodInfo<(Of <(<'T>)>)> Class


AddContent Method

[image] [image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..AddContent Method
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddContent(IEnumerable<(Of <<'(T>)>>)) | Adds items to the time period's content list.
Public method | AddContent(T) | Adds an item to the time period's content list.

See Also

PeriodInfo<(Of <(<'T>)>)> Class
PeriodInfo<(Of <(<'T>)>)> Members


AddContent Method (IEnumerable(T))

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..AddContent Method (IEnumerable<(Of <(<'T>)>)>)
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Adds items to the time period's content list.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void AddContent(
    IEnumerable<T> items
)
Visual Basic
Public Sub AddContent ( _
    items As IEnumerable(Of T) _
)
Visual C++
public:
void AddContent(
    IEnumerable<T>^ items
)

Parameters

items
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' T >)>)>
The items to add.

See Also

PeriodInfo<(Of <(<'T>)>)> Class
AddContent Overload


AddContent Method (T)

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..AddContent Method (T)
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Adds an item to the time period's content list.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void AddContent(
    T item
)
Visual Basic
Public Sub AddContent ( _
    item As T _
)
Visual C++
public:
void AddContent(
    T item
)

Parameters

item
Type: T
The item to add.

See Also

PeriodInfo<(Of <(<'T>)>)> Class
AddContent Overload


Overlaps Method

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..Overlaps Method
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Returns true if the given period overlaps in time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public bool Overlaps(
    PeriodInfo<T> p
)
Visual Basic
Public Function Overlaps ( _
    p As PeriodInfo(Of T) _
) As Boolean
Visual C++
public:
bool Overlaps(
    PeriodInfo<T>^ p
)

Parameters

p
Type: Zeptomoby.OrbitTools.Track..::..PeriodInfo <(Of <(<' T >)>)>

[Missing <param name="p"/> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.Overlaps(Zeptomoby.OrbitTools.Track.PeriodInfo{`0})"]

Return Value

[Missing <returns> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.Overlaps(Zeptomoby.OrbitTools.Track.PeriodInfo{`0})"]

See Also

PeriodInfo<(Of <(<'T>)>)> Class


ToString Method

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..ToString Method
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
Shows the start, stop times and the period overlap count.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Zeptomoby.OrbitTools.Track.PeriodInfo`1.ToString"]

See Also

PeriodInfo<(Of <(<'T>)>)> Class


PeriodInfo(T) Properties

[image] [image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)> Properties
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback

The PeriodInfo<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | Content | The content list associated with the time period.
Public property | OverlapCount | The period overlap count.
Public property | Start | The starting time of the period.
Public property | Stop | The ending time of the period.

See Also

PeriodInfo<(Of <(<'T>)>)> Class


Content Property

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..Content Property
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
The content list associated with the time period.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public ReadOnlyCollection<T> Content { get; }
Visual Basic
Public ReadOnly Property Content As ReadOnlyCollection(Of T)
    Get
Visual C++
public:
property ReadOnlyCollection<T>^ Content {
    ReadOnlyCollection<T>^ get ();
}

See Also

PeriodInfo<(Of <(<'T>)>)> Class


OverlapCount Property

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..OverlapCount Property
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
The period overlap count.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public int OverlapCount { get; private set; }
Visual Basic
Public Property OverlapCount As Integer
    Get
    Private Set
Visual C++
public:
property int OverlapCount {
    int get ();
    private: void set (int value);
}

See Also

PeriodInfo<(Of <(<'T>)>)> Class


Start Property

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..Start Property
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
The starting time of the period.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public DateTime Start { get; private set; }
Visual Basic
Public Property Start As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Start {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

PeriodInfo<(Of <(<'T>)>)> Class


Stop Property

[image]

OrbitTools Track Library Documentation
PeriodInfo<(Of <(<'T>)>)>..::..Stop Property
PeriodInfo<(Of <(<'T>)>)> Class See Also Send Feedback
The ending time of the period.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public DateTime Stop { get; private set; }
Visual Basic
Public Property Stop As DateTime
    Get
    Private Set
Visual C++
public:
property DateTime Stop {
    DateTime get ();
    private: void set (DateTime value);
}

See Also

PeriodInfo<(Of <(<'T>)>)> Class


Schedule(T) Class

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Class
Members See Also Send Feedback
Class to manage a list of sorted time periods, and provide information regarding which periods overlap in time. Each time period has optional "content", which is a list of type T.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public sealed class Schedule<T>
Visual Basic
Public NotInheritable Class Schedule(Of T)
Visual C++
generic<typename T>
public ref class Schedule sealed

Type Parameters

T
Specifies the type of the "content" that is stored in each PeriodInfo object.

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..Schedule<(Of <(<'T>)>)>

See Also

Schedule<(Of <(<'T>)>)> Members


Schedule(T) Members

[image] [image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Members
Schedule<(Of <(<'T>)>)> Class Constructors Methods Properties See Also Send Feedback

The Schedule<(Of <(<'T>)>)> type exposes the following members.

Constructors

 | Name | Description
Public method | Schedule<(Of <(<'T>)>)>()()()() | Standard constructor.
Public method | Schedule<(Of <(<'T>)>)>(IEnumerable<(Of <<'(PeriodInfo<(Of <<'(T>)>>)>)>>)) | Constructor accepting enumerable list of periods.

Methods

 | Name | Description
Public method | AddPeriod(IEnumerable<(Of <<'(PeriodInfo<(Of <<'(T>)>>)>)>>)) | Adds time periods to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | AddPeriod(PeriodInfo<(Of <<'(T>)>>)) | Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | AddPeriod(DateTime, DateTime, T) | Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Periods()()()() | The collection of time periods, sorted by start time.
Public method | Periods(Int32, Int32) | The collection of time periods, sorted by start time, that have an overlap count that falls between the two given values.
Public method | ToString | Shows all the periods in the sorted period list. (Overrides Object..::..ToString()()()().)

Properties

 | Name | Description
Public property | AllSortOverlapCount | The collection of time periods, sorted by lowest to highest overlap count.
Public property | AllSortOverlapCountDesc | The collection of time periods, sorted by highest to lowest overlap count.
Public property | OverlapMax | The collection of time periods that have the highest overlap count.
Public property | OverlapMin | The collection of time periods that have the lowest overlap count.

See Also

Schedule<(Of <(<'T>)>)> Class


Schedule(T) Constructor

[image] [image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Constructor
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Schedule<(Of <(<'T>)>)>()()()() | Standard constructor.
Public method | Schedule<(Of <(<'T>)>)>(IEnumerable<(Of <<'(PeriodInfo<(Of <<'(T>)>>)>)>>)) | Constructor accepting enumerable list of periods.

See Also

Schedule<(Of <(<'T>)>)> Class
Schedule<(Of <(<'T>)>)> Members


Schedule(T) Constructor

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Constructor
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Schedule()
Visual Basic
Public Sub New
Visual C++
public:
Schedule()

See Also

Schedule<(Of <(<'T>)>)> Class
Schedule<(Of <(<'T>)>)> Overload


Schedule(T) Constructor (IEnumerable(PeriodInfo(T)))

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Constructor (IEnumerable<(Of <(<'PeriodInfo<(Of <(<'T>)>)>>)>)>)
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
Constructor accepting enumerable list of periods.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Schedule(
    IEnumerable<PeriodInfo<T>> periods
)
Visual Basic
Public Sub New ( _
    periods As IEnumerable(Of PeriodInfo(Of T)) _
)
Visual C++
public:
Schedule(
    IEnumerable<PeriodInfo<T>^>^ periods
)

Parameters

periods
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' PeriodInfo <(Of <(<' T >)>)>>)>)>

[Missing <param name="periods"/> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.#ctor(System.Collections.Generic.IEnumerable{Zeptomoby.OrbitTools.Track.PeriodInfo{`0}})"]

See Also

Schedule<(Of <(<'T>)>)> Class
Schedule<(Of <(<'T>)>)> Overload


Schedule(T) Methods

[image] [image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Methods
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback

The Schedule<(Of <(<'T>)>)> type exposes the following members.

Methods

 | Name | Description
Public method | AddPeriod(IEnumerable<(Of <<'(PeriodInfo<(Of <<'(T>)>>)>)>>)) | Adds time periods to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | AddPeriod(PeriodInfo<(Of <<'(T>)>>)) | Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | AddPeriod(DateTime, DateTime, T) | Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Periods()()()() | The collection of time periods, sorted by start time.
Public method | Periods(Int32, Int32) | The collection of time periods, sorted by start time, that have an overlap count that falls between the two given values.
Public method | ToString | Shows all the periods in the sorted period list. (Overrides Object..::..ToString()()()().)

See Also

Schedule<(Of <(<'T>)>)> Class


AddPeriod Method

[image] [image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..AddPeriod Method
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | AddPeriod(IEnumerable<(Of <<'(PeriodInfo<(Of <<'(T>)>>)>)>>)) | Adds time periods to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | AddPeriod(PeriodInfo<(Of <<'(T>)>>)) | Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.
Public method | AddPeriod(DateTime, DateTime, T) | Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.

See Also

Schedule<(Of <(<'T>)>)> Class
Schedule<(Of <(<'T>)>)> Members


AddPeriod Method (IEnumerable(PeriodInfo(T)))

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..AddPeriod Method (IEnumerable<(Of <(<'PeriodInfo<(Of <(<'T>)>)>>)>)>)
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
Adds time periods to the schedule. Any overlapping periods that are currently present in the schedule are combined.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void AddPeriod(
    IEnumerable<PeriodInfo<T>> periods
)
Visual Basic
Public Sub AddPeriod ( _
    periods As IEnumerable(Of PeriodInfo(Of T)) _
)
Visual C++
public:
void AddPeriod(
    IEnumerable<PeriodInfo<T>^>^ periods
)

Parameters

periods
Type: System.Collections.Generic..::..IEnumerable<(Of <(<' PeriodInfo <(Of <(<' T >)>)>>)>)>

[Missing <param name="periods"/> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.AddPeriod(System.Collections.Generic.IEnumerable{Zeptomoby.OrbitTools.Track.PeriodInfo{`0}})"]

See Also

Schedule<(Of <(<'T>)>)> Class
AddPeriod Overload


AddPeriod Method (PeriodInfo(T))

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..AddPeriod Method (PeriodInfo<(Of <(<'T>)>)>)
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void AddPeriod(
    PeriodInfo<T> period
)
Visual Basic
Public Sub AddPeriod ( _
    period As PeriodInfo(Of T) _
)
Visual C++
public:
void AddPeriod(
    PeriodInfo<T>^ period
)

Parameters

period
Type: Zeptomoby.OrbitTools.Track..::..PeriodInfo <(Of <(<' T >)>)>
The time period to add.

See Also

Schedule<(Of <(<'T>)>)> Class
AddPeriod Overload


AddPeriod Method (DateTime, DateTime, T)

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..AddPeriod Method (DateTime, DateTime, T)
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
Adds a time period to the schedule. Any overlapping periods that are currently present in the schedule are combined.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public void AddPeriod(
    DateTime start,
    DateTime stop,
    T content
)
Visual Basic
Public Sub AddPeriod ( _
    start As DateTime, _
    stop As DateTime, _
    content As T _
)
Visual C++
public:
void AddPeriod(
    DateTime start,
    DateTime stop,
    T content
)

Parameters

start
Type: System..::..DateTime
The period start time.
stop
Type: System..::..DateTime
The period stop time.
content
Type: T
Optional content associated with the period.

See Also

Schedule<(Of <(<'T>)>)> Class
AddPeriod Overload


Periods Method

[image] [image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..Periods Method
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback

Overload List

 | Name | Description
Public method | Periods()()()() | The collection of time periods, sorted by start time.
Public method | Periods(Int32, Int32) | The collection of time periods, sorted by start time, that have an overlap count that falls between the two given values.

See Also

Schedule<(Of <(<'T>)>)> Class
Schedule<(Of <(<'T>)>)> Members


Periods Method

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..Periods Method
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
The collection of time periods, sorted by start time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public IEnumerable<PeriodInfo<T>> Periods()
Visual Basic
Public Function Periods As IEnumerable(Of PeriodInfo(Of T))
Visual C++
public:
IEnumerable<PeriodInfo<T>^>^ Periods()

Return Value

[Missing <returns> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.Periods"]

See Also

Schedule<(Of <(<'T>)>)> Class
Periods Overload


Periods Method (Int32, Int32)

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..Periods Method (Int32, Int32)
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
The collection of time periods, sorted by start time, that have an overlap count that falls between the two given values.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public IEnumerable<PeriodInfo<T>> Periods(
    int minOverlap,
    int maxOverlap
)
Visual Basic
Public Function Periods ( _
    minOverlap As Integer, _
    maxOverlap As Integer _
) As IEnumerable(Of PeriodInfo(Of T))
Visual C++
public:
IEnumerable<PeriodInfo<T>^>^ Periods(
    int minOverlap,
    int maxOverlap
)

Parameters

minOverlap
Type: System..::..Int32

[Missing <param name="minOverlap"/> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.Periods(System.Int32,System.Int32)"]

maxOverlap
Type: System..::..Int32

[Missing <param name="maxOverlap"/> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.Periods(System.Int32,System.Int32)"]

Return Value

[Missing <returns> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.Periods(System.Int32,System.Int32)"]

See Also

Schedule<(Of <(<'T>)>)> Class
Periods Overload


ToString Method

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..ToString Method
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
Shows all the periods in the sorted period list.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public override string ToString()
Visual Basic
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for "M:Zeptomoby.OrbitTools.Track.Schedule`1.ToString"]

See Also

Schedule<(Of <(<'T>)>)> Class


Schedule(T) Properties

[image] [image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)> Properties
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback

The Schedule<(Of <(<'T>)>)> type exposes the following members.

Properties

 | Name | Description
Public property | AllSortOverlapCount | The collection of time periods, sorted by lowest to highest overlap count.
Public property | AllSortOverlapCountDesc | The collection of time periods, sorted by highest to lowest overlap count.
Public property | OverlapMax | The collection of time periods that have the highest overlap count.
Public property | OverlapMin | The collection of time periods that have the lowest overlap count.

See Also

Schedule<(Of <(<'T>)>)> Class


AllSortOverlapCount Property

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..AllSortOverlapCount Property
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
The collection of time periods, sorted by lowest to highest overlap count.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public IEnumerable<PeriodInfo<T>> AllSortOverlapCount { get; }
Visual Basic
Public ReadOnly Property AllSortOverlapCount As IEnumerable(Of PeriodInfo(Of T))
    Get
Visual C++
public:
property IEnumerable<PeriodInfo<T>^>^ AllSortOverlapCount {
    IEnumerable<PeriodInfo<T>^>^ get ();
}

See Also

Schedule<(Of <(<'T>)>)> Class


AllSortOverlapCountDesc Property

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..AllSortOverlapCountDesc Property
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
The collection of time periods, sorted by highest to lowest overlap count.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public IEnumerable<PeriodInfo<T>> AllSortOverlapCountDesc { get; }
Visual Basic
Public ReadOnly Property AllSortOverlapCountDesc As IEnumerable(Of PeriodInfo(Of T))
    Get
Visual C++
public:
property IEnumerable<PeriodInfo<T>^>^ AllSortOverlapCountDesc {
    IEnumerable<PeriodInfo<T>^>^ get ();
}

See Also

Schedule<(Of <(<'T>)>)> Class


OverlapMax Property

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..OverlapMax Property
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
The collection of time periods that have the highest overlap count.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public IEnumerable<PeriodInfo<T>> OverlapMax { get; }
Visual Basic
Public ReadOnly Property OverlapMax As IEnumerable(Of PeriodInfo(Of T))
    Get
Visual C++
public:
property IEnumerable<PeriodInfo<T>^>^ OverlapMax {
    IEnumerable<PeriodInfo<T>^>^ get ();
}

See Also

Schedule<(Of <(<'T>)>)> Class


OverlapMin Property

[image]

OrbitTools Track Library Documentation
Schedule<(Of <(<'T>)>)>..::..OverlapMin Property
Schedule<(Of <(<'T>)>)> Class See Also Send Feedback
The collection of time periods that have the lowest overlap count.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public IEnumerable<PeriodInfo<T>> OverlapMin { get; }
Visual Basic
Public ReadOnly Property OverlapMin As IEnumerable(Of PeriodInfo(Of T))
    Get
Visual C++
public:
property IEnumerable<PeriodInfo<T>^>^ OverlapMin {
    IEnumerable<PeriodInfo<T>^>^ get ();
}

See Also

Schedule<(Of <(<'T>)>)> Class


Solar Class

[image]

OrbitTools Track Library Documentation
Solar Class
Members See Also Send Feedback
Utility class used to provide Sun-related data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static class Solar
Visual Basic
Public NotInheritable Class Solar
Visual C++
public ref class Solar abstract sealed

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..Solar

See Also

Solar Members


Solar Members

[image] [image]

OrbitTools Track Library Documentation
Solar Members
Solar Class Methods See Also Send Feedback

The Solar type exposes the following members.

Methods

Name | Description
PositionEci | Calculates the ECI position of the Sun.

See Also

Solar Class


Solar Methods

[image] [image]

OrbitTools Track Library Documentation
Solar Methods
Solar Class See Also Send Feedback

The Solar type exposes the following members.

Methods

Name | Description
PositionEci | Calculates the ECI position of the Sun.

See Also

Solar Class


PositionEci Method

[image]

OrbitTools Track Library Documentation
Solar..::..PositionEci Method
Solar Class See Also Send Feedback
Calculates the ECI position of the Sun.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EciTime PositionEci(
    Julian time
)
Visual Basic
Public Shared Function PositionEci ( _
    time As Julian _
) As EciTime
Visual C++
public:
static EciTime^ PositionEci(
    Julian^ time
)

Parameters

time
Type: Julian
Time for which the Sun position is calculated.

Return Value

The location of the Sun, in kilometer-based ECI coordinates.

Remarks

References: "Astronomical Formulae for Calculators", Jean Meeus, chapters 18, 19. "Visually Observing Earth Satellites", Dr. T.S. Kelso, Satellite Times, September/October issue 1996.

See Also

Solar Class


Station Class

[image]

OrbitTools Track Library Documentation
Station Class
Members See Also Send Feedback
An Earth location that supports sky mask capability.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public class Station : Site
Visual Basic
Public Class Station _
    Inherits Site
Visual C++
public ref class Station : public Site

Inheritance Hierarchy

System..::..Object
Site
Zeptomoby.OrbitTools.Track..::..Station

See Also

Station Members


Station Members

[image] [image]

OrbitTools Track Library Documentation
Station Members
Station Class Constructors Methods Properties See Also Send Feedback

The Station type exposes the following members.

Constructors

 | Name | Description
Public method | Station | Standard constructor.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLookAngle | (Inherited from Site.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PositionEci(Julian) | (Inherited from Site.)
Public method | PositionEci(DateTime) | (Inherited from Site.)
Public method | ToString | (Inherited from Site.)

Extension Methods

 | Name | Description
Public Extension Method | CalcPassData(Satellite, DateTime, DateTime, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon. (Defined by Track.)
Public Extension Method | CalcPassData(Satellite, Double, Double, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon. (Defined by Track.)
Public Extension Method | CalcPassData(Satellite, DateTime, DateTime, Boolean, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon and (optionally) pass segment data. (Defined by Track.)
Public Extension Method | CalcPassData(Satellite, Double, Double, Boolean, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon and (optionally) pass segment data. (Defined by Track.)
Public Extension Method | InSunlight(DateTime, Double) | Overloaded. Determines if a location on earth is illuminated by the sun. (Defined by Track.)
Public Extension Method | InSunlight(Julian, Double) | Overloaded. Determines if a location on earth is illuminated by the sun. (Defined by Track.)
Public Extension Method | IsoElevationCircle(DateTime, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircle(Julian, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEcf(DateTime, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEcf(Julian, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEci(DateTime, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEci(Julian, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)

Properties

 | Name | Description
Public property | Altitude | (Inherited from Site.)
Public property | Geo | (Inherited from Site.)
Public property | HorizonMasks | List of masks defining areas of the sky that are obscured.
Public property | LatitudeDeg | (Inherited from Site.)
Public property | LatitudeRad | (Inherited from Site.)
Public property | LongitudeDeg | (Inherited from Site.)
Public property | LongitudeRad | (Inherited from Site.)
Public property | Name | (Inherited from Site.)
Public property | WgsModel | (Inherited from Site.)

See Also

Station Class


Station Constructor

[image]

OrbitTools Track Library Documentation
Station Constructor
Station Class See Also Send Feedback
Standard constructor.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public Station(
    double degLat,
    double degLon,
    double kmAlt,
    WgsModel model,
    List<IMask> masks,
    string name
)
Visual Basic
Public Sub New ( _
    degLat As Double, _
    degLon As Double, _
    kmAlt As Double, _
    model As WgsModel, _
    masks As List(Of IMask), _
    name As String _
)
Visual C++
public:
Station(
    double degLat,
    double degLon,
    double kmAlt,
    WgsModel^ model,
    List<IMask^>^ masks,
    String^ name
)

Parameters

degLat
Type: System..::..Double
Latitude in degrees (negative south).
degLon
Type: System..::..Double
Longitude in degrees (negative west).
kmAlt
Type: System..::..Double
Altitude in kilometers.
model
Type: WgsModel
The earth ellipsoid model.
masks
Type: System.Collections.Generic..::..List<(Of <(<' IMask >)>)>
List of masks defining areas of the sky which are not viewable from the station.
name
Type: System..::..String
The site name.

See Also

Station Class


Station Methods

[image] [image]

OrbitTools Track Library Documentation
Station Methods
Station Class See Also Send Feedback

The Station type exposes the following members.

Methods

 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLookAngle | (Inherited from Site.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PositionEci(Julian) | (Inherited from Site.)
Public method | PositionEci(DateTime) | (Inherited from Site.)
Public method | ToString | (Inherited from Site.)

Extension Methods

 | Name | Description
Public Extension Method | CalcPassData(Satellite, DateTime, DateTime, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon. (Defined by Track.)
Public Extension Method | CalcPassData(Satellite, Double, Double, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon. (Defined by Track.)
Public Extension Method | CalcPassData(Satellite, DateTime, DateTime, Boolean, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon and (optionally) pass segment data. (Defined by Track.)
Public Extension Method | CalcPassData(Satellite, Double, Double, Boolean, Boolean, Boolean) | Overloaded. Calculate satellite pass data for a local horizon and (optionally) pass segment data. (Defined by Track.)
Public Extension Method | InSunlight(DateTime, Double) | Overloaded. Determines if a location on earth is illuminated by the sun. (Defined by Track.)
Public Extension Method | InSunlight(Julian, Double) | Overloaded. Determines if a location on earth is illuminated by the sun. (Defined by Track.)
Public Extension Method | IsoElevationCircle(DateTime, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircle(Julian, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEcf(DateTime, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEcf(Julian, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEci(DateTime, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)
Public Extension Method | IsoElevationCircleEci(Julian, Double, Double, Double, Double) | Overloaded. Calculates an elevation circle centered on an earth site. (Defined by Track.)

See Also

Station Class


PositionEci Method

[image] [image]

OrbitTools Track Library Documentation
Station..::..PositionEci Method
Station Class See Also Send Feedback

Overload List

 | Name | Description
Public method | PositionEci(Julian) | (Inherited from Site.)
Public method | PositionEci(DateTime) | (Inherited from Site.)

See Also

Station Class
Station Members


Station Properties

[image] [image]

OrbitTools Track Library Documentation
Station Properties
Station Class See Also Send Feedback

The Station type exposes the following members.

Properties

 | Name | Description
Public property | Altitude | (Inherited from Site.)
Public property | Geo | (Inherited from Site.)
Public property | HorizonMasks | List of masks defining areas of the sky that are obscured.
Public property | LatitudeDeg | (Inherited from Site.)
Public property | LatitudeRad | (Inherited from Site.)
Public property | LongitudeDeg | (Inherited from Site.)
Public property | LongitudeRad | (Inherited from Site.)
Public property | Name | (Inherited from Site.)
Public property | WgsModel | (Inherited from Site.)

See Also

Station Class


HorizonMasks Property

[image]

OrbitTools Track Library Documentation
Station..::..HorizonMasks Property
Station Class See Also Send Feedback
List of masks defining areas of the sky that are obscured.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public List<IMask> HorizonMasks { get; }
Visual Basic
Public ReadOnly Property HorizonMasks As List(Of IMask)
    Get
Visual C++
public:
property List<IMask^>^ HorizonMasks {
    List<IMask^>^ get ();
}

See Also

Station Class


Track Class

[image]

OrbitTools Track Library Documentation
Track Class
Members See Also Send Feedback
This class contains the top-level methods that comprise the core functionality of the OrbitTools Track Library.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static class Track
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Track
Visual C++
[ExtensionAttribute]
public ref class Track abstract sealed

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..Track

See Also

Track Members


Track Members

[image] [image]

OrbitTools Track Library Documentation
Track Members
Track Class Methods See Also Send Feedback

The Track type exposes the following members.

Methods

Name | Description
CalcApsides(IOrbit, Double) | Calculates an orbit's apogee and perigee information.
CalcApsides(IOrbit, Double, Double) | Calculates an orbit's apogee and perigee information.
CalcAscendingNode | Calculates the ascending node information of an orbit.
CalcDescendingNode | Calculates the descending node information of an orbit.
CalcNodes | Calculates the ascending and descending node information of an orbit.
CalcPassData(Site, Satellite, DateTime, DateTime, Boolean, Boolean) | Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.
CalcPassData(Site, Satellite, Double, Double, Boolean, Boolean) | Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.
CalcPassData(Station, Satellite, DateTime, DateTime, Boolean, Boolean, Boolean) | Calculate satellite pass data for a local horizon and (optionally) pass segment data.
CalcPassData(Station, Satellite, Double, Double, Boolean, Boolean, Boolean) | Calculate satellite pass data for a local horizon and (optionally) pass segment data.
CoverageContour(Satellite, DateTime, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.
CoverageContour(Satellite, Double, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.
CoverageContourEci(Satellite, DateTime, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.
CoverageContourEci(Satellite, Double, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.
GroundTrack(Satellite, DateTime, DateTime, Double, Double) | Returns the equidistant LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, DateTime, DateTime, TimeSpan, Double) | Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, Double, Double, Double, Double) | Returns the equidistant LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, Double, Double, TimeSpan, Double) | Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.
GroundTrackEcf(Satellite, DateTime, DateTime, Double, Double) | Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, DateTime, DateTime, TimeSpan, Double) | Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, Double, Double, Double, Double) | Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, Double, Double, TimeSpan, Double) | Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.
InSunlight(EciTime, WgsModel) | Determines if an ECI coordinate point is illuminated by the sun.
InSunlight(Satellite, DateTime) | Determines if a satellite is illuminated by the sun.
InSunlight(Satellite, Julian) | Determines if a satellite is illuminated by the sun.
InSunlight(Site, DateTime, Double) | Determines if a location on earth is illuminated by the sun.
InSunlight(Site, Julian, Double) | Determines if a location on earth is illuminated by the sun.
IsoElevationCircle(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircle(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircle(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircle(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircle(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.
IsoElevationCircleEcf(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEcf(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEcf(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEcf(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEcf(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.
IsoElevationCircleEci(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEci(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEci(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEci(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEci(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.
OrbitTrack(Satellite, DateTime, DateTime, Double) | Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, DateTime, DateTime, TimeSpan) | Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, Double, Double, Double) | Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, Double, Double, TimeSpan) | Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.
SolarSubpoint(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpoint(WgsModel, Julian, Double) | Calculates the Sun's subpoint.
SolarSubpointEcf(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpointEcf(WgsModel, Julian, Double) | Calculates the Sun's subpoint.
SolarSubpointEci(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpointEci(WgsModel, Julian, Double) | Calculates the Sun's subpoint.
SolarTerminator(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminator(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEcf(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEcf(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEci(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEci(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
Subpoint(IOrbit, DateTime, Double) | Returns the orbit subpoint at a given time.
Subpoint(IOrbit, Double, Double) | Returns the orbit subpoint at a given time.
Subpoint(Satellite, DateTime, Double) | Returns the satellite subpoint at a given time.
Subpoint(Satellite, Double, Double) | Returns the satellite subpoint at a given time.
SubpointEcf(IOrbit, DateTime, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(IOrbit, Double, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(Satellite, DateTime, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(Satellite, Double, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.

See Also

Track Class


Track Methods

[image] [image]

OrbitTools Track Library Documentation
Track Methods
Track Class See Also Send Feedback

The Track type exposes the following members.

Methods

Name | Description
CalcApsides(IOrbit, Double) | Calculates an orbit's apogee and perigee information.
CalcApsides(IOrbit, Double, Double) | Calculates an orbit's apogee and perigee information.
CalcAscendingNode | Calculates the ascending node information of an orbit.
CalcDescendingNode | Calculates the descending node information of an orbit.
CalcNodes | Calculates the ascending and descending node information of an orbit.
CalcPassData(Site, Satellite, DateTime, DateTime, Boolean, Boolean) | Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.
CalcPassData(Site, Satellite, Double, Double, Boolean, Boolean) | Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.
CalcPassData(Station, Satellite, DateTime, DateTime, Boolean, Boolean, Boolean) | Calculate satellite pass data for a local horizon and (optionally) pass segment data.
CalcPassData(Station, Satellite, Double, Double, Boolean, Boolean, Boolean) | Calculate satellite pass data for a local horizon and (optionally) pass segment data.
CoverageContour(Satellite, DateTime, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.
CoverageContour(Satellite, Double, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.
CoverageContourEci(Satellite, DateTime, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.
CoverageContourEci(Satellite, Double, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.
GroundTrack(Satellite, DateTime, DateTime, Double, Double) | Returns the equidistant LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, DateTime, DateTime, TimeSpan, Double) | Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, Double, Double, Double, Double) | Returns the equidistant LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, Double, Double, TimeSpan, Double) | Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.
GroundTrackEcf(Satellite, DateTime, DateTime, Double, Double) | Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, DateTime, DateTime, TimeSpan, Double) | Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, Double, Double, Double, Double) | Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, Double, Double, TimeSpan, Double) | Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.
InSunlight(EciTime, WgsModel) | Determines if an ECI coordinate point is illuminated by the sun.
InSunlight(Satellite, DateTime) | Determines if a satellite is illuminated by the sun.
InSunlight(Satellite, Julian) | Determines if a satellite is illuminated by the sun.
InSunlight(Site, DateTime, Double) | Determines if a location on earth is illuminated by the sun.
InSunlight(Site, Julian, Double) | Determines if a location on earth is illuminated by the sun.
IsoElevationCircle(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircle(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircle(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircle(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircle(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.
IsoElevationCircleEcf(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEcf(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEcf(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEcf(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEcf(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.
IsoElevationCircleEci(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEci(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEci(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEci(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEci(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.
OrbitTrack(Satellite, DateTime, DateTime, Double) | Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, DateTime, DateTime, TimeSpan) | Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, Double, Double, Double) | Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, Double, Double, TimeSpan) | Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.
SolarSubpoint(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpoint(WgsModel, Julian, Double) | Calculates the Sun's subpoint.
SolarSubpointEcf(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpointEcf(WgsModel, Julian, Double) | Calculates the Sun's subpoint.
SolarSubpointEci(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpointEci(WgsModel, Julian, Double) | Calculates the Sun's subpoint.
SolarTerminator(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminator(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEcf(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEcf(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEci(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEci(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
Subpoint(IOrbit, DateTime, Double) | Returns the orbit subpoint at a given time.
Subpoint(IOrbit, Double, Double) | Returns the orbit subpoint at a given time.
Subpoint(Satellite, DateTime, Double) | Returns the satellite subpoint at a given time.
Subpoint(Satellite, Double, Double) | Returns the satellite subpoint at a given time.
SubpointEcf(IOrbit, DateTime, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(IOrbit, Double, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(Satellite, DateTime, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(Satellite, Double, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.

See Also

Track Class


CalcApsides Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..CalcApsides Method
Track Class See Also Send Feedback

Overload List

Name | Description
CalcApsides(IOrbit, Double) | Calculates an orbit's apogee and perigee information.
CalcApsides(IOrbit, Double, Double) | Calculates an orbit's apogee and perigee information.

See Also

Track Class
Track Members


CalcApsides Method (, Double)

[image]

OrbitTools Track Library Documentation
Track..::..CalcApsides Method (, Double)
Track Class See Also Send Feedback
Calculates an orbit's apogee and perigee information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Apsis> CalcApsides(
    this IOrbit orbit,
    double mpe
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcApsides ( _
    orbit As IOrbit, _
    mpe As Double _
) As List(Of Apsis)
Visual C++
[ExtensionAttribute]
public:
static List<Apsis^>^ CalcApsides(
    IOrbit^ orbit,
    double mpe
)

Parameters

orbit
Type: IOrbit
The orbit.
mpe
Type: System..::..Double
Identifies the target orbit; the ascending node occurs at or before this minutes-past-epoch time. In format.

Return Value

A list containing both of the calculated apsides, or a partial list if the orbit decays during processing.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
CalcApsides Overload


CalcApsides Method (, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..CalcApsides Method (, Double, Double)
Track Class See Also Send Feedback
Calculates an orbit's apogee and perigee information.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Apsis> CalcApsides(
    this IOrbit orbit,
    double mpeStart,
    double mpeStop
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcApsides ( _
    orbit As IOrbit, _
    mpeStart As Double, _
    mpeStop As Double _
) As List(Of Apsis)
Visual C++
[ExtensionAttribute]
public:
static List<Apsis^>^ CalcApsides(
    IOrbit^ orbit,
    double mpeStart,
    double mpeStop
)

Parameters

orbit
Type: IOrbit
The orbit.
mpeStart
Type: System..::..Double
The start time of the target orbit (ascending node of the current orbit).
mpeStop
Type: System..::..Double
The end time of the target orbit (abuts ascending node of next orbit).

Return Value

A list containing the calculated apsides.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
CalcApsides Overload


CalcAscendingNode Method

[image]

OrbitTools Track Library Documentation
Track..::..CalcAscendingNode Method
Track Class See Also Send Feedback
Calculates the ascending node information of an orbit.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static Node CalcAscendingNode(
    this IOrbit orbit,
    double mpe
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcAscendingNode ( _
    orbit As IOrbit, _
    mpe As Double _
) As Node
Visual C++
[ExtensionAttribute]
public:
static Node^ CalcAscendingNode(
    IOrbit^ orbit,
    double mpe
)

Parameters

orbit
Type: IOrbit
The target orbit.
mpe
Type: System..::..Double
Identifies the orbit revolution; the orbit's ascending node occurs at or before this time. In minutes-past-epoch format.

Return Value

The ascending node information, or null if the orbit decays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class


CalcDescendingNode Method

[image]

OrbitTools Track Library Documentation
Track..::..CalcDescendingNode Method
Track Class See Also Send Feedback
Calculates the descending node information of an orbit.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static Node CalcDescendingNode(
    this IOrbit orbit,
    double mpe
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcDescendingNode ( _
    orbit As IOrbit, _
    mpe As Double _
) As Node
Visual C++
[ExtensionAttribute]
public:
static Node^ CalcDescendingNode(
    IOrbit^ orbit,
    double mpe
)

Parameters

orbit
Type: IOrbit
The target orbit.
mpe
Type: System..::..Double
Identifies the target orbit revolution; the orbit's descending node occurs at or before this time. In minutes-past-epoch format.

Return Value

The descending node information, or null if the orbit decays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class


CalcNodes Method

[image]

OrbitTools Track Library Documentation
Track..::..CalcNodes Method
Track Class See Also Send Feedback
Calculates the ascending and descending node information of an orbit.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Node> CalcNodes(
    this IOrbit orbit,
    double mpe
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcNodes ( _
    orbit As IOrbit, _
    mpe As Double _
) As List(Of Node)
Visual C++
[ExtensionAttribute]
public:
static List<Node^>^ CalcNodes(
    IOrbit^ orbit,
    double mpe
)

Parameters

orbit
Type: IOrbit
The orbit.
mpe
Type: System..::..Double
Identifies the target orbit; the orbit's ascending node occurs at or before this time. In minutes-past-epoch format.

Return Value

A list containing both of the calculated nodes, or a partial/empty list if the orbit decays during processing, or an empty list if the orbit inclination is near zero degrees.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class


CalcPassData Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..CalcPassData Method
Track Class See Also Send Feedback

Overload List

Name | Description
CalcPassData(Site, Satellite, DateTime, DateTime, Boolean, Boolean) | Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.
CalcPassData(Site, Satellite, Double, Double, Boolean, Boolean) | Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.
CalcPassData(Station, Satellite, DateTime, DateTime, Boolean, Boolean, Boolean) | Calculate satellite pass data for a local horizon and (optionally) pass segment data.
CalcPassData(Station, Satellite, Double, Double, Boolean, Boolean, Boolean) | Calculate satellite pass data for a local horizon and (optionally) pass segment data.

See Also

Track Class
Track Members


CalcPassData Method (, , DateTime, DateTime, Boolean, Boolean)

[image]

OrbitTools Track Library Documentation
Track..::..CalcPassData Method (, , DateTime, DateTime, Boolean, Boolean)
Track Class See Also Send Feedback
Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<PassData> CalcPassData(
    this Site site,
    Satellite sat,
    DateTime t1,
    DateTime t2,
    bool includeMax,
    bool useParallel
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcPassData ( _
    site As Site, _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    includeMax As Boolean, _
    useParallel As Boolean _
) As IList(Of PassData)
Visual C++
[ExtensionAttribute]
public:
static IList<PassData^>^ CalcPassData(
    Site^ site,
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    bool includeMax,
    bool useParallel
)

Parameters

site
Type: Site
The Earth site for which events are calculated.
sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time (UTC).
t2
Type: System..::..DateTime
The stop time (UTC).
includeMax
Type: System..::..Boolean
If true, maximum visibility event data is included in the returned data.
useParallel
Type: System..::..Boolean
If true, the algorithm executes in parallel mode.

Return Value

A list of PassData objects containing the AOS/MAX/LOS event data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

A satellite rising above the horizon, then setting below the horizon, is a single pass. This method will calculate all passes of a satellite over a given local horizon for the given time period. The method will also optionally calculate the maximum elevation above the local horizon that the satellite obtains during each pass. Setting the useParallel parameter to false forces the algorithm to execute serially. Serial execution may improve performance when searching smaller time spans.

See Also

Track Class
CalcPassData Overload


CalcPassData Method (, , Double, Double, Boolean, Boolean)

[image]

OrbitTools Track Library Documentation
Track..::..CalcPassData Method (, , Double, Double, Boolean, Boolean)
Track Class See Also Send Feedback
Calculate satellite pass data for a local horizon using a parallel algorithm. The data includes rise time (AOS), set time (LOS), and optionally, the maximum elevation (MAX) above the horizon.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<PassData> CalcPassData(
    this Site site,
    Satellite sat,
    double t1,
    double t2,
    bool includeMax,
    bool useParallel
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcPassData ( _
    site As Site, _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    includeMax As Boolean, _
    useParallel As Boolean _
) As IList(Of PassData)
Visual C++
[ExtensionAttribute]
public:
static IList<PassData^>^ CalcPassData(
    Site^ site,
    Satellite^ sat,
    double t1,
    double t2,
    bool includeMax,
    bool useParallel
)

Parameters

site
Type: Site
The Earth site for which events are calculated.
sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time (minutes-past-epoch).
t2
Type: System..::..Double
The stop time (minutes-past-epoch).
includeMax
Type: System..::..Boolean
If true, maximum visibility events are included in the returned data.
useParallel
Type: System..::..Boolean
If true, the algorithm executes in parallel.

Return Value

A list of PassData objects containing the AOS/MAX/LOS events.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

A satellite rising above the horizon, then setting below the horizon, is a single pass. This method will calculate all passes of a satellite over a given local horizon for the given time period. The method will also optionally calculate the maximum elevation above the local horizon that the satellite obtains during each pass. Setting the useParallel parameter to false forces the algorithm to execute serially. Serial execution may improve performance when searching smaller time spans.

See Also

Track Class
CalcPassData Overload


CalcPassData Method (Station, , DateTime, DateTime, Boolean, Boolean, Boolean)

[image]

OrbitTools Track Library Documentation
Track..::..CalcPassData Method (Station, , DateTime, DateTime, Boolean, Boolean, Boolean)
Track Class See Also Send Feedback
Calculate satellite pass data for a local horizon and (optionally) pass segment data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<PassData> CalcPassData(
    this Station station,
    Satellite sat,
    DateTime t1,
    DateTime t2,
    bool includeMax,
    bool includeSegments,
    bool useParallel
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcPassData ( _
    station As Station, _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    includeMax As Boolean, _
    includeSegments As Boolean, _
    useParallel As Boolean _
) As IList(Of PassData)
Visual C++
[ExtensionAttribute]
public:
static IList<PassData^>^ CalcPassData(
    Station^ station,
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    bool includeMax,
    bool includeSegments,
    bool useParallel
)

Parameters

station
Type: Zeptomoby.OrbitTools.Track..::..Station
The Earth station for which data are calculated.
sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time (UTC).
t2
Type: System..::..DateTime
The stop time (UTC).
includeMax
Type: System..::..Boolean
If true, maximum visibility events are calculated and included in the returned data.
includeSegments
Type: System..::..Boolean
If true, pass segment information is calculated and included in the returned data.
useParallel
Type: System..::..Boolean
If true, the algorithm executes in parallel mode.

Return Value

A list of PassData objects containing the AOS/MAX/LOS event data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Station. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

A satellite rising above the horizon, then setting below the horizon, is a single pass. This method will calculate all passes of a satellite over a given local horizon for the given time period. The method will also optionally calculate the maximum elevation above the local horizon that the satellite obtains during each pass. Setting the useParallel parameter to false forces the algorithm to execute serially. Serial execution may improve performance when searching smaller time spans.

See Also

Track Class
CalcPassData Overload


CalcPassData Method (Station, , Double, Double, Boolean, Boolean, Boolean)

[image]

OrbitTools Track Library Documentation
Track..::..CalcPassData Method (Station, , Double, Double, Boolean, Boolean, Boolean)
Track Class See Also Send Feedback
Calculate satellite pass data for a local horizon and (optionally) pass segment data.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<PassData> CalcPassData(
    this Station station,
    Satellite sat,
    double t1,
    double t2,
    bool includeMax,
    bool includeSegments,
    bool useParallel
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcPassData ( _
    station As Station, _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    includeMax As Boolean, _
    includeSegments As Boolean, _
    useParallel As Boolean _
) As IList(Of PassData)
Visual C++
[ExtensionAttribute]
public:
static IList<PassData^>^ CalcPassData(
    Station^ station,
    Satellite^ sat,
    double t1,
    double t2,
    bool includeMax,
    bool includeSegments,
    bool useParallel
)

Parameters

station
Type: Zeptomoby.OrbitTools.Track..::..Station
The Earth station for which data are calculated.
sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time (minutes-past-epoch).
t2
Type: System..::..Double
The stop time (minutes-past-epoch).
includeMax
Type: System..::..Boolean
If true, maximum visibility events are calculated and included in the returned data.
includeSegments
Type: System..::..Boolean
If true, pass segment information is calculated and included in the returned data.
useParallel
Type: System..::..Boolean
If true, the algorithm executes in parallel.

Return Value

A list of PassData objects containing the AOS/MAX/LOS events.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Station. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

A satellite rising above the horizon, then setting below the horizon, is a single pass. This method will calculate all passes of a satellite over a given local horizon for the given time period. The method will also optionally calculate the maximum elevation above the local horizon that the satellite obtains during each pass. Setting the useParallel parameter to false forces the algorithm to execute serially. Serial execution may improve performance when searching smaller time spans.

See Also

Track Class
CalcPassData Overload


CoverageContour Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..CoverageContour Method
Track Class See Also Send Feedback

Overload List

Name | Description
CoverageContour(Satellite, DateTime, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.
CoverageContour(Satellite, Double, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.

See Also

Track Class
Track Members


CoverageContour Method (, DateTime, , IBeamProfile, Int32, Boolean, Double)

[image]

OrbitTools Track Library Documentation
Track..::..CoverageContour Method (, DateTime, , IBeamProfile, Int32, Boolean, Double)
Track Class See Also Send Feedback
Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> CoverageContour(
    this Satellite sat,
    DateTime utc,
    Site beamTarget,
    IBeamProfile beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CoverageContour ( _
    sat As Satellite, _
    utc As DateTime, _
    beamTarget As Site, _
    beamProfile As IBeamProfile, _
    numPoints As Integer, _
    closedPath As Boolean, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ CoverageContour(
    Satellite^ sat,
    DateTime utc,
    Site^ beamTarget,
    IBeamProfile^ beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite that is the beam source.
utc
Type: System..::..DateTime
Time of calculation (UTC).
beamTarget
Type: Site
The beam "boresight" target location.
beamProfile
Type: Zeptomoby.OrbitTools.Track..::..IBeamProfile
Describes the cross sectional shape of the beam.
numPoints
Type: System..::..Int32
The number of contour points to calculate.
closedPath
Type: System..::..Boolean
If true, a list of points that describe a closed path is returned, even if the beam does not fully intersect the ellipsoid model.
kmLoft
Type: System..::..Double
The height of the set of points above the earth ellipsoid model, in kilometers.

Return Value

A list of geodetic points that describe the intersection of a transmission beam and an earth ellipsoid model.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
CoverageContour Overload


CoverageContour Method (, Double, , IBeamProfile, Int32, Boolean, Double)

[image]

OrbitTools Track Library Documentation
Track..::..CoverageContour Method (, Double, , IBeamProfile, Int32, Boolean, Double)
Track Class See Also Send Feedback
Calculates a coverage contour profile for a beam transmitted from a satellite to a target location on Earth.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> CoverageContour(
    this Satellite sat,
    double mpe,
    Site beamTarget,
    IBeamProfile beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CoverageContour ( _
    sat As Satellite, _
    mpe As Double, _
    beamTarget As Site, _
    beamProfile As IBeamProfile, _
    numPoints As Integer, _
    closedPath As Boolean, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ CoverageContour(
    Satellite^ sat,
    double mpe,
    Site^ beamTarget,
    IBeamProfile^ beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite that is the beam source.
mpe
Type: System..::..Double
Time of calculation, in minutes-past-epoch.
beamTarget
Type: Site
The beam "boresight" target location.
beamProfile
Type: Zeptomoby.OrbitTools.Track..::..IBeamProfile
Describes the cross sectional shape of the beam.
numPoints
Type: System..::..Int32
The number of contour points to calculate.
closedPath
Type: System..::..Boolean
If true, a list of points that describe a closed path is returned, even if the beam does not fully intersect the ellipsoid model.
kmLoft
Type: System..::..Double
The height of the set of points above the earth ellipsoid model, in kilometers.

Return Value

A list of geodetic points that describe the intersection of a transmission beam and an earth ellipsoid model.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
CoverageContour Overload


CoverageContourEci Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..CoverageContourEci Method
Track Class See Also Send Feedback

Overload List

Name | Description
CoverageContourEci(Satellite, DateTime, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.
CoverageContourEci(Satellite, Double, Site, IBeamProfile, Int32, Boolean, Double) | Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.

See Also

Track Class
Track Members


CoverageContourEci Method (, DateTime, , IBeamProfile, Int32, Boolean, Double)

[image]

OrbitTools Track Library Documentation
Track..::..CoverageContourEci Method (, DateTime, , IBeamProfile, Int32, Boolean, Double)
Track Class See Also Send Feedback
Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> CoverageContourEci(
    this Satellite sat,
    DateTime utc,
    Site beamTarget,
    IBeamProfile beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CoverageContourEci ( _
    sat As Satellite, _
    utc As DateTime, _
    beamTarget As Site, _
    beamProfile As IBeamProfile, _
    numPoints As Integer, _
    closedPath As Boolean, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ CoverageContourEci(
    Satellite^ sat,
    DateTime utc,
    Site^ beamTarget,
    IBeamProfile^ beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite that is the beam source.
utc
Type: System..::..DateTime
Time of calculation (UTC).
beamTarget
Type: Site
The beam "boresight" target location.
beamProfile
Type: Zeptomoby.OrbitTools.Track..::..IBeamProfile
Describes the cross sectional shape of the beam.
numPoints
Type: System..::..Int32
The number of contour points to calculate.
closedPath
Type: System..::..Boolean
If true, a list of points that describe a closed path is returned, even if the beam does not fully intersect the ellipsoid model.
kmLoft
Type: System..::..Double
The height of the set of points above the earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinates that describe the intersection of a transmission beam and an earth ellipsoid model.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
CoverageContourEci Overload


CoverageContourEci Method (, Double, , IBeamProfile, Int32, Boolean, Double)

[image]

OrbitTools Track Library Documentation
Track..::..CoverageContourEci Method (, Double, , IBeamProfile, Int32, Boolean, Double)
Track Class See Also Send Feedback
Calculates a coverage contour profile for a beam transmitted from a satellite to a location on Earth.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> CoverageContourEci(
    this Satellite sat,
    double mpe,
    Site beamTarget,
    IBeamProfile beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CoverageContourEci ( _
    sat As Satellite, _
    mpe As Double, _
    beamTarget As Site, _
    beamProfile As IBeamProfile, _
    numPoints As Integer, _
    closedPath As Boolean, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ CoverageContourEci(
    Satellite^ sat,
    double mpe,
    Site^ beamTarget,
    IBeamProfile^ beamProfile,
    int numPoints,
    bool closedPath,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite that is the beam source.
mpe
Type: System..::..Double
Time of calculation, in minutes-past-epoch.
beamTarget
Type: Site
The beam "boresight" target location.
beamProfile
Type: Zeptomoby.OrbitTools.Track..::..IBeamProfile
Describes the cross sectional shape of the beam.
numPoints
Type: System..::..Int32
The number of contour points to calculate.
closedPath
Type: System..::..Boolean
If true, a list of points that describe a closed path is returned, even if the beam does not fully intersect the ellipsoid model.
kmLoft
Type: System..::..Double
The height of the set of points above the earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinates that describe the intersection of a transmission beam and an earth ellipsoid model.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
CoverageContourEci Overload


GroundTrack Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..GroundTrack Method
Track Class See Also Send Feedback

Overload List

Name | Description
GroundTrack(Satellite, DateTime, DateTime, Double, Double) | Returns the equidistant LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, DateTime, DateTime, TimeSpan, Double) | Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, Double, Double, Double, Double) | Returns the equidistant LAT/LON coordinates of a satellite ground track.
GroundTrack(Satellite, Double, Double, TimeSpan, Double) | Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.

See Also

Track Class
Track Members


GroundTrack Method (, DateTime, DateTime, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrack Method (, DateTime, DateTime, Double, Double)
Track Class See Also Send Feedback
Returns the equidistant LAT/LON coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<GeoTime> GroundTrack(
    this Satellite sat,
    DateTime t1,
    DateTime t2,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrack ( _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    kmSpacing As Double, _
    kmLoft As Double _
) As IList(Of GeoTime)
Visual C++
[ExtensionAttribute]
public:
static IList<GeoTime^>^ GroundTrack(
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The end time.
kmSpacing
Type: System..::..Double
Distance, in kilometers, between each point in the ground track (approximate).
kmLoft
Type: System..::..Double
The desired height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of equidistant LAT/LON coordinate points that define the subpoint locations of the satellite over the given time period. The last point in the list corresponds to time "t2" regardless of distance spacing.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrack Overload


GroundTrack Method (, DateTime, DateTime, TimeSpan, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrack Method (, DateTime, DateTime, TimeSpan, Double)
Track Class See Also Send Feedback
Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<GeoTime> GroundTrack(
    this Satellite sat,
    DateTime t1,
    DateTime t2,
    TimeSpan dt,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrack ( _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    dt As TimeSpan, _
    kmLoft As Double _
) As IList(Of GeoTime)
Visual C++
[ExtensionAttribute]
public:
static IList<GeoTime^>^ GroundTrack(
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    TimeSpan dt,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time, in UTC.
t2
Type: System..::..DateTime
The end time, in UTC.
dt
Type: System..::..TimeSpan
Time elapsed between each point in the ground track.
kmLoft
Type: System..::..Double
The height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of LAT/LON coordinate points that define the subpoint locations of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrack Overload


GroundTrack Method (, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrack Method (, Double, Double, Double, Double)
Track Class See Also Send Feedback
Returns the equidistant LAT/LON coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<GeoTime> GroundTrack(
    this Satellite sat,
    double t1,
    double t2,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrack ( _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As IList(Of GeoTime)
Visual C++
[ExtensionAttribute]
public:
static IList<GeoTime^>^ GroundTrack(
    Satellite^ sat,
    double t1,
    double t2,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time, in minutes-past-epoch.
t2
Type: System..::..Double
The end time, in minutes-past-epoch.
kmSpacing
Type: System..::..Double
Distance, in kilometers, between each point in the ground track.
kmLoft
Type: System..::..Double
The desired height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of equidistant LAT/LON coordinate points that define the subpoint locations of the satellite over the given time period. The last point in the list corresponds to time "t2" regardless of distance spacing.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrack Overload


GroundTrack Method (, Double, Double, TimeSpan, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrack Method (, Double, Double, TimeSpan, Double)
Track Class See Also Send Feedback
Returns the equal time-spaced LAT/LON coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<GeoTime> GroundTrack(
    this Satellite sat,
    double t1,
    double t2,
    TimeSpan dt,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrack ( _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    dt As TimeSpan, _
    kmLoft As Double _
) As IList(Of GeoTime)
Visual C++
[ExtensionAttribute]
public:
static IList<GeoTime^>^ GroundTrack(
    Satellite^ sat,
    double t1,
    double t2,
    TimeSpan dt,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time, in minutes-past-epoch.
t2
Type: System..::..Double
The stop time, in minutes-past-epoch.
dt
Type: System..::..TimeSpan
Time elapsed between each point in the ground track.
kmLoft
Type: System..::..Double
The desired height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of LAT/LON coordinate points that define the subpoint locations of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrack Overload


GroundTrackEcf Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..GroundTrackEcf Method
Track Class See Also Send Feedback

Overload List

Name | Description
GroundTrackEcf(Satellite, DateTime, DateTime, Double, Double) | Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, DateTime, DateTime, TimeSpan, Double) | Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, Double, Double, Double, Double) | Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.
GroundTrackEcf(Satellite, Double, Double, TimeSpan, Double) | Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.

See Also

Track Class
Track Members


GroundTrackEcf Method (, DateTime, DateTime, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrackEcf Method (, DateTime, DateTime, Double, Double)
Track Class See Also Send Feedback
Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<EcfTime> GroundTrackEcf(
    this Satellite sat,
    DateTime t1,
    DateTime t2,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrackEcf ( _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    kmSpacing As Double, _
    kmLoft As Double _
) As IList(Of EcfTime)
Visual C++
[ExtensionAttribute]
public:
static IList<EcfTime^>^ GroundTrackEcf(
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The end time.
kmSpacing
Type: System..::..Double
Distance, in kilometers, between each point in the ground track (approximate).
kmLoft
Type: System..::..Double
The desired height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of equidistant ECF coordinate points that define the subpoint locations of the satellite over the given time period. The last point in the list corresponds to time "t2" regardless of distance spacing.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrackEcf Overload


GroundTrackEcf Method (, DateTime, DateTime, TimeSpan, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrackEcf Method (, DateTime, DateTime, TimeSpan, Double)
Track Class See Also Send Feedback
Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<EcfTime> GroundTrackEcf(
    this Satellite sat,
    DateTime t1,
    DateTime t2,
    TimeSpan dt,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrackEcf ( _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    dt As TimeSpan, _
    kmLoft As Double _
) As IList(Of EcfTime)
Visual C++
[ExtensionAttribute]
public:
static IList<EcfTime^>^ GroundTrackEcf(
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    TimeSpan dt,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time, in UTC.
t2
Type: System..::..DateTime
The end time, in UTC.
dt
Type: System..::..TimeSpan
Time elapsed between each point in the ground track.
kmLoft
Type: System..::..Double
The height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that define the subpoint locations of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrackEcf Overload


GroundTrackEcf Method (, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrackEcf Method (, Double, Double, Double, Double)
Track Class See Also Send Feedback
Returns the equidistant Earth Centered Fixed coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<EcfTime> GroundTrackEcf(
    this Satellite sat,
    double t1,
    double t2,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrackEcf ( _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As IList(Of EcfTime)
Visual C++
[ExtensionAttribute]
public:
static IList<EcfTime^>^ GroundTrackEcf(
    Satellite^ sat,
    double t1,
    double t2,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time, in minutes-past-epoch.
t2
Type: System..::..Double
The end time, in minutes-past-epoch.
kmSpacing
Type: System..::..Double
Distance, in kilometers, between each point in the ground track.
kmLoft
Type: System..::..Double
The desired height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of equidistant ECF coordinate points that define the subpoint locations of the satellite over the given time period. The last point in the list corresponds to time "t2" regardless of distance spacing.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrackEcf Overload


GroundTrackEcf Method (, Double, Double, TimeSpan, Double)

[image]

OrbitTools Track Library Documentation
Track..::..GroundTrackEcf Method (, Double, Double, TimeSpan, Double)
Track Class See Also Send Feedback
Returns the equal time-spaced Earth Centered Fixed coordinates of a satellite ground track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<EcfTime> GroundTrackEcf(
    this Satellite sat,
    double t1,
    double t2,
    TimeSpan dt,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function GroundTrackEcf ( _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    dt As TimeSpan, _
    kmLoft As Double _
) As IList(Of EcfTime)
Visual C++
[ExtensionAttribute]
public:
static IList<EcfTime^>^ GroundTrackEcf(
    Satellite^ sat,
    double t1,
    double t2,
    TimeSpan dt,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time, in minutes-past-epoch.
t2
Type: System..::..Double
The stop time, in minutes-past-epoch.
dt
Type: System..::..TimeSpan
Time elapsed between each point in the ground track.
kmLoft
Type: System..::..Double
The desired height of the ground track points above the Earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that define the subpoint locations of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
GroundTrackEcf Overload


InSunlight Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..InSunlight Method
Track Class See Also Send Feedback

Overload List

Name | Description
InSunlight(EciTime, WgsModel) | Determines if an ECI coordinate point is illuminated by the sun.
InSunlight(Satellite, DateTime) | Determines if a satellite is illuminated by the sun.
InSunlight(Satellite, Julian) | Determines if a satellite is illuminated by the sun.
InSunlight(Site, DateTime, Double) | Determines if a location on earth is illuminated by the sun.
InSunlight(Site, Julian, Double) | Determines if a location on earth is illuminated by the sun.

See Also

Track Class
Track Members


InSunlight Method (, )

[image]

OrbitTools Track Library Documentation
Track..::..InSunlight Method (, )
Track Class See Also Send Feedback
Determines if an ECI coordinate point is illuminated by the sun.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static bool InSunlight(
    this EciTime eci,
    WgsModel ellipsoid
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InSunlight ( _
    eci As EciTime, _
    ellipsoid As WgsModel _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InSunlight(
    EciTime^ eci,
    WgsModel^ ellipsoid
)

Parameters

eci
Type: EciTime
The ECI coordinate point.
ellipsoid
Type: WgsModel
Earth ellipsoid model.

Return Value

Returns 'true' if the given coordinate point is illuminated by the sun. A point is considered illuminated if it is not in the Earth's shadow.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type EciTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
InSunlight Overload


InSunlight Method (, DateTime)

[image]

OrbitTools Track Library Documentation
Track..::..InSunlight Method (, DateTime)
Track Class See Also Send Feedback
Determines if a satellite is illuminated by the sun.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static bool InSunlight(
    this Satellite sat,
    DateTime utc
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InSunlight ( _
    sat As Satellite, _
    utc As DateTime _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InSunlight(
    Satellite^ sat,
    DateTime utc
)

Parameters

sat
Type: Satellite
The satellite.
utc
Type: System..::..DateTime
The time of calculation.

Return Value

Returns 'true' if the satellite is illuminated by the sun. A satellite is considered illuminated if it is not in the Earth's shadow.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
InSunlight Overload


InSunlight Method (, )

[image]

OrbitTools Track Library Documentation
Track..::..InSunlight Method (, )
Track Class See Also Send Feedback
Determines if a satellite is illuminated by the sun.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static bool InSunlight(
    this Satellite sat,
    Julian date
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InSunlight ( _
    sat As Satellite, _
    date As Julian _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InSunlight(
    Satellite^ sat,
    Julian^ date
)

Parameters

sat
Type: Satellite
The satellite.
date
Type: Julian
The time of calculation.

Return Value

Returns 'true' if the satellite is illuminated by the sun. A satellite is considered illuminated if it is not in the Earth's shadow.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
InSunlight Overload


InSunlight Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..InSunlight Method (, DateTime, Double)
Track Class See Also Send Feedback
Determines if a location on earth is illuminated by the sun.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static bool InSunlight(
    this Site site,
    DateTime utc,
    double degTwilight
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InSunlight ( _
    site As Site, _
    utc As DateTime, _
    degTwilight As Double _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InSunlight(
    Site^ site,
    DateTime utc,
    double degTwilight
)

Parameters

site
Type: Site
The earth location.
utc
Type: System..::..DateTime
Time of calculation (UTC).
degTwilight
Type: System..::..Double
The elevation angle of the sun when twilight begins, in degrees.

Return Value

Returns 'true' if the site is illuminated by sunlight. The site is assumed to be in sunlight for all sun elevation angles that exceed the twilight angle.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

Some common twilight angles, in degrees: -6.0 Civil Twilight -12.0 Nautical Twilight -18.0 Astronomical Twilight

See Also

Track Class
InSunlight Overload


InSunlight Method (, , Double)

[image]

OrbitTools Track Library Documentation
Track..::..InSunlight Method (, , Double)
Track Class See Also Send Feedback
Determines if a location on earth is illuminated by the sun.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static bool InSunlight(
    this Site site,
    Julian date,
    double degTwilight
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function InSunlight ( _
    site As Site, _
    date As Julian, _
    degTwilight As Double _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool InSunlight(
    Site^ site,
    Julian^ date,
    double degTwilight
)

Parameters

site
Type: Site
The earth location.
date
Type: Julian
Time of calculation.
degTwilight
Type: System..::..Double
The elevation angle of the sun when twilight begins, in degrees.

Return Value

Returns 'true' if the site is illuminated by sunlight. The site is assumed to be in sunlight for all sun elevation angles that exceed the twilight angle.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

Some common twilight angles, in degrees: -6.0 Civil Twilight -12.0 Nautical Twilight -18.0 Astronomical Twilight

See Also

Track Class
InSunlight Overload


IsoElevationCircle Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircle Method
Track Class See Also Send Feedback

Overload List

Name | Description
IsoElevationCircle(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircle(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircle(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircle(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircle(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.

See Also

Track Class
Track Members


IsoElevationCircle Method (, DateTime, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircle Method (, DateTime, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on a satellite subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> IsoElevationCircle(
    this Satellite sat,
    DateTime utc,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircle ( _
    sat As Satellite, _
    utc As DateTime, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ IsoElevationCircle(
    Satellite^ sat,
    DateTime utc,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
utc
Type: System..::..DateTime
Time of calculation (UTC).
degAngle
Type: System..::..Double
The viewing angle, from the earth to the satellite, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the Earth ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points that form a circle on the surface of the earth. The points all have the same angle of elevation to the given satellite.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

When the elevation angle of the points is specified as zero, the points form the satellite's "circle of visibility", which represents the area of the earth visible from the spacecraft.

See Also

Track Class
IsoElevationCircle Overload


IsoElevationCircle Method (, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircle Method (, Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on a satellite subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> IsoElevationCircle(
    this Satellite sat,
    double mpe,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircle ( _
    sat As Satellite, _
    mpe As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ IsoElevationCircle(
    Satellite^ sat,
    double mpe,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
mpe
Type: System..::..Double
Time of calculation, in minutes-past-epoch.
degAngle
Type: System..::..Double
The viewing angle, from the earth to the satellite, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the Earth ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points that form a circle on the surface of the earth. The points all have the same angle of elevation to the given satellite.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

When the elevation angle of the points is specified as zero, the points form the satellite's "circle of visibility", which represents the area of the earth visible from the spacecraft.

See Also

Track Class
IsoElevationCircle Overload


IsoElevationCircle Method (, DateTime, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircle Method (, DateTime, Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on an earth site.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> IsoElevationCircle(
    this Site site,
    DateTime utc,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircle ( _
    site As Site, _
    utc As DateTime, _
    kmTargetAlt As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ IsoElevationCircle(
    Site^ site,
    DateTime utc,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

site
Type: Site
The earth site.
utc
Type: System..::..DateTime
Time of calculation (UTC).
kmTargetAlt
Type: System..::..Double
Target location, in kilometers directly above the earth site.
degAngle
Type: System..::..Double
The viewing angle, from the earth site to an arbitrary target height, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points that form a circle on the surface of the earth, centered around a given site location. The points all have the same viewing angle of elevation to a target point located at an arbitrary distance above the site.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircle Overload


IsoElevationCircle Method (, , Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircle Method (, , Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on an earth site.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> IsoElevationCircle(
    this Site site,
    Julian date,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircle ( _
    site As Site, _
    date As Julian, _
    kmTargetAlt As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ IsoElevationCircle(
    Site^ site,
    Julian^ date,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

site
Type: Site
The earth site.
date
Type: Julian
Time of calculation.
kmTargetAlt
Type: System..::..Double
Target location, in kilometers directly above the earth site.
degAngle
Type: System..::..Double
The viewing angle, from the earth site to an arbitrary target height, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points that form a circle on the surface of the earth, centered around a given site location. The points all have the same viewing angle of elevation to a target point located at an arbitrary distance above the site.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircle Overload


IsoElevationCircle Method (, , , Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircle Method (, , , Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle on an ellipsoid model.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> IsoElevationCircle(
    this WgsModel ellipsoid,
    EciTime subpoint,
    Eci target,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircle ( _
    ellipsoid As WgsModel, _
    subpoint As EciTime, _
    target As Eci, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ IsoElevationCircle(
    WgsModel^ ellipsoid,
    EciTime^ subpoint,
    Eci^ target,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The ellipsoid model.
subpoint
Type: EciTime
The center location of elevation circle.
target
Type: Eci
The target location.
degAngle
Type: System..::..Double
The viewing angle, from the circle perimeter to the target location, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of Geodetic coordinate points that form a circle on the ellipsoid, centered around a given subpoint location. The points all have the same viewing angle of elevation to the given target location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircle Overload


IsoElevationCircleEcf Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEcf Method
Track Class See Also Send Feedback

Overload List

Name | Description
IsoElevationCircleEcf(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEcf(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEcf(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEcf(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEcf(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.

See Also

Track Class
Track Members


IsoElevationCircleEcf Method (, DateTime, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEcf Method (, DateTime, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on a satellite subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> IsoElevationCircleEcf(
    this Satellite sat,
    DateTime utc,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEcf ( _
    sat As Satellite, _
    utc As DateTime, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ IsoElevationCircleEcf(
    Satellite^ sat,
    DateTime utc,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
utc
Type: System..::..DateTime
Time of calculation (UTC).
degAngle
Type: System..::..Double
The viewing angle, from the earth to the satellite, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the Earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that form a circle on the surface of the earth. The points all have the same angle of elevation to the given satellite.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

When the elevation angle of the points is specified as zero, the points form the satellite's "circle of visibility", which represents the area of the earth visible from the spacecraft.

See Also

Track Class
IsoElevationCircleEcf Overload


IsoElevationCircleEcf Method (, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEcf Method (, Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on a satellite subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> IsoElevationCircleEcf(
    this Satellite sat,
    double mpe,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEcf ( _
    sat As Satellite, _
    mpe As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ IsoElevationCircleEcf(
    Satellite^ sat,
    double mpe,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
mpe
Type: System..::..Double
Time of calculation, in minutes-past-epoch.
degAngle
Type: System..::..Double
The viewing angle, from the earth to the satellite, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the Earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that form a circle on the surface of the earth. The points all have the same angle of elevation to the given satellite.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

When the elevation angle of the points is specified as zero, the points form the satellite's "circle of visibility", which represents the area of the earth visible from the spacecraft.

See Also

Track Class
IsoElevationCircleEcf Overload


IsoElevationCircleEcf Method (, DateTime, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEcf Method (, DateTime, Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on an earth site.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> IsoElevationCircleEcf(
    this Site site,
    DateTime utc,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEcf ( _
    site As Site, _
    utc As DateTime, _
    kmTargetAlt As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ IsoElevationCircleEcf(
    Site^ site,
    DateTime utc,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

site
Type: Site
The earth site.
utc
Type: System..::..DateTime
Time of calculation (UTC).
kmTargetAlt
Type: System..::..Double
Target location, in kilometers directly above the earth site.
degAngle
Type: System..::..Double
The viewing angle, from the earth site to an arbitrary target height, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that form a circle on the surface of the earth, centered around a given site location. The points all have the same viewing angle of elevation to a target point located at an arbitrary distance above the site.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircleEcf Overload


IsoElevationCircleEcf Method (, , Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEcf Method (, , Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on an earth site.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> IsoElevationCircleEcf(
    this Site site,
    Julian date,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEcf ( _
    site As Site, _
    date As Julian, _
    kmTargetAlt As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ IsoElevationCircleEcf(
    Site^ site,
    Julian^ date,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

site
Type: Site
The earth site.
date
Type: Julian
Time of calculation.
kmTargetAlt
Type: System..::..Double
Target location, in kilometers directly above the earth site.
degAngle
Type: System..::..Double
The viewing angle, from the earth site to an arbitrary target height, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that form a circle on the surface of the earth, centered around a given site location. The points all have the same viewing angle of elevation to a target point located at an arbitrary distance above the site.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircleEcf Overload


IsoElevationCircleEcf Method (, , , Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEcf Method (, , , Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle on an ellipsoid model.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> IsoElevationCircleEcf(
    this WgsModel ellipsoid,
    EciTime subpoint,
    Eci target,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEcf ( _
    ellipsoid As WgsModel, _
    subpoint As EciTime, _
    target As Eci, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ IsoElevationCircleEcf(
    WgsModel^ ellipsoid,
    EciTime^ subpoint,
    Eci^ target,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The ellipsoid model.
subpoint
Type: EciTime
The center location of elevation circle.
target
Type: Eci
The target location.
degAngle
Type: System..::..Double
The viewing angle, from the circle center to the target location, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of ECF coordinate points that form a circle on the ellipsoid, centered around a given subpoint location. The points all have the same viewing angle of elevation to the given target location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircleEcf Overload


IsoElevationCircleEci Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEci Method
Track Class See Also Send Feedback

Overload List

Name | Description
IsoElevationCircleEci(Satellite, DateTime, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEci(Satellite, Double, Double, Double, Double) | Calculates an elevation circle centered on a satellite subpoint.
IsoElevationCircleEci(Site, DateTime, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEci(Site, Julian, Double, Double, Double, Double) | Calculates an elevation circle centered on an earth site.
IsoElevationCircleEci(WgsModel, EciTime, Eci, Double, Double, Double) | Calculates an elevation circle on an ellipsoid model.

See Also

Track Class
Track Members


IsoElevationCircleEci Method (, DateTime, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEci Method (, DateTime, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on a satellite subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> IsoElevationCircleEci(
    this Satellite sat,
    DateTime utc,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEci ( _
    sat As Satellite, _
    utc As DateTime, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ IsoElevationCircleEci(
    Satellite^ sat,
    DateTime utc,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
utc
Type: System..::..DateTime
Time of calculation (UTC).
degAngle
Type: System..::..Double
The viewing angle, from the earth to the satellite, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the Earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points that form a circle on the surface of the earth. The points all have the same angle of elevation to the given satellite.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

When the elevation angle of the points is specified as zero, the points form the satellite's "circle of visibility", which represents the area of the earth visible from the spacecraft.

See Also

Track Class
IsoElevationCircleEci Overload


IsoElevationCircleEci Method (, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEci Method (, Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on a satellite subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> IsoElevationCircleEci(
    this Satellite sat,
    double mpe,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEci ( _
    sat As Satellite, _
    mpe As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ IsoElevationCircleEci(
    Satellite^ sat,
    double mpe,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
mpe
Type: System..::..Double
Time of calculation, in minutes-past-epoch.
degAngle
Type: System..::..Double
The viewing angle, from the earth to the satellite, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the Earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points that form a circle on the surface of the earth. The points all have the same angle of elevation to the given satellite.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

When the elevation angle of the points is specified as zero, the points form the satellite's "circle of visibility", which represents the area of the earth visible from the spacecraft.

See Also

Track Class
IsoElevationCircleEci Overload


IsoElevationCircleEci Method (, DateTime, Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEci Method (, DateTime, Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on an earth site.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> IsoElevationCircleEci(
    this Site site,
    DateTime utc,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEci ( _
    site As Site, _
    utc As DateTime, _
    kmTargetAlt As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ IsoElevationCircleEci(
    Site^ site,
    DateTime utc,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

site
Type: Site
The earth site.
utc
Type: System..::..DateTime
Time of calculation (UTC).
kmTargetAlt
Type: System..::..Double
Target location, in kilometers directly above the earth site.
degAngle
Type: System..::..Double
The viewing angle, from the earth site to an arbitrary target height, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points that form a circle on the surface of the earth, centered around a given site location. The points all have the same viewing angle of elevation to a target point located at an arbitrary distance above the site.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircleEci Overload


IsoElevationCircleEci Method (, , Double, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEci Method (, , Double, Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle centered on an earth site.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> IsoElevationCircleEci(
    this Site site,
    Julian date,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEci ( _
    site As Site, _
    date As Julian, _
    kmTargetAlt As Double, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ IsoElevationCircleEci(
    Site^ site,
    Julian^ date,
    double kmTargetAlt,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

site
Type: Site
The earth site.
date
Type: Julian
Time of calculation.
kmTargetAlt
Type: System..::..Double
Target location, in kilometers directly above the earth site.
degAngle
Type: System..::..Double
The viewing angle, from the earth site to an arbitrary target height, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points that form a circle on the surface of the earth, centered around a given site location. The points all have the same viewing angle of elevation to a target point located at an arbitrary distance above the site.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Site. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircleEci Overload


IsoElevationCircleEci Method (, , , Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..IsoElevationCircleEci Method (, , , Double, Double, Double)
Track Class See Also Send Feedback
Calculates an elevation circle on an ellipsoid model.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> IsoElevationCircleEci(
    this WgsModel ellipsoid,
    EciTime subpoint,
    Eci target,
    double degAngle,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function IsoElevationCircleEci ( _
    ellipsoid As WgsModel, _
    subpoint As EciTime, _
    target As Eci, _
    degAngle As Double, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ IsoElevationCircleEci(
    WgsModel^ ellipsoid,
    EciTime^ subpoint,
    Eci^ target,
    double degAngle,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The ellipsoid model.
subpoint
Type: EciTime
The center location of elevation circle.
target
Type: Eci
The target location.
degAngle
Type: System..::..Double
The viewing angle, from the circle center to the target location, [0..90] degrees.
kmSpacing
Type: System..::..Double
The distance between each point in the circle, in kilometers.
kmLoft
Type: System..::..Double
The height of the circle above the earth ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points that form a circle on the ellipsoid, centered around a given subpoint location. The points all have the same viewing angle of elevation to the given target location.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
IsoElevationCircleEci Overload


OrbitTrack Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..OrbitTrack Method
Track Class See Also Send Feedback

Overload List

Name | Description
OrbitTrack(Satellite, DateTime, DateTime, Double) | Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, DateTime, DateTime, TimeSpan) | Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, Double, Double, Double) | Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.
OrbitTrack(Satellite, Double, Double, TimeSpan) | Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.

See Also

Track Class
Track Members


OrbitTrack Method (, DateTime, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..OrbitTrack Method (, DateTime, DateTime, Double)
Track Class See Also Send Feedback
Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<Eci> OrbitTrack(
    this Satellite sat,
    DateTime t1,
    DateTime t2,
    double kmSpacing
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function OrbitTrack ( _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    kmSpacing As Double _
) As IList(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static IList<Eci^>^ OrbitTrack(
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    double kmSpacing
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The end time.
kmSpacing
Type: System..::..Double
The distance between points, in kilometers (approximate).

Return Value

A list of equidistant ECI coordinate points that define the location of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
OrbitTrack Overload


OrbitTrack Method (, DateTime, DateTime, TimeSpan)

[image]

OrbitTools Track Library Documentation
Track..::..OrbitTrack Method (, DateTime, DateTime, TimeSpan)
Track Class See Also Send Feedback
Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<Eci> OrbitTrack(
    this Satellite sat,
    DateTime t1,
    DateTime t2,
    TimeSpan dt
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function OrbitTrack ( _
    sat As Satellite, _
    t1 As DateTime, _
    t2 As DateTime, _
    dt As TimeSpan _
) As IList(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static IList<Eci^>^ OrbitTrack(
    Satellite^ sat,
    DateTime t1,
    DateTime t2,
    TimeSpan dt
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..DateTime
The start time.
t2
Type: System..::..DateTime
The end time.
dt
Type: System..::..TimeSpan
Time elapsed between each point.

Return Value

A list of ECI coordinate points that define the location of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
OrbitTrack Overload


OrbitTrack Method (, Double, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..OrbitTrack Method (, Double, Double, Double)
Track Class See Also Send Feedback
Returns the equidistant Earth Centered Inertial coordinates of a satellite orbit track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<Eci> OrbitTrack(
    this Satellite sat,
    double t1,
    double t2,
    double kmSpacing
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function OrbitTrack ( _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    kmSpacing As Double _
) As IList(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static IList<Eci^>^ OrbitTrack(
    Satellite^ sat,
    double t1,
    double t2,
    double kmSpacing
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time.
t2
Type: System..::..Double
The end time.
kmSpacing
Type: System..::..Double
The distance between points, in kilometers (approximate).

Return Value

A list of equidistant ECI coordinate points that define the location of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
OrbitTrack Overload


OrbitTrack Method (, Double, Double, TimeSpan)

[image]

OrbitTools Track Library Documentation
Track..::..OrbitTrack Method (, Double, Double, TimeSpan)
Track Class See Also Send Feedback
Returns the equal time-spaced Earth Centered Inertial coordinates of a satellite orbit track.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static IList<Eci> OrbitTrack(
    this Satellite sat,
    double t1,
    double t2,
    TimeSpan dt
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function OrbitTrack ( _
    sat As Satellite, _
    t1 As Double, _
    t2 As Double, _
    dt As TimeSpan _
) As IList(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static IList<Eci^>^ OrbitTrack(
    Satellite^ sat,
    double t1,
    double t2,
    TimeSpan dt
)

Parameters

sat
Type: Satellite
The satellite.
t1
Type: System..::..Double
The start time.
t2
Type: System..::..Double
The end time.
dt
Type: System..::..TimeSpan
Time elapsed between each point.

Return Value

A list of ECI coordinate points that define the location of the satellite over the given time period.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
OrbitTrack Overload


SolarSubpoint Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SolarSubpoint Method
Track Class See Also Send Feedback

Overload List

Name | Description
SolarSubpoint(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpoint(WgsModel, Julian, Double) | Calculates the Sun's subpoint.

See Also

Track Class
Track Members


SolarSubpoint Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarSubpoint Method (, DateTime, Double)
Track Class See Also Send Feedback
Calculates the Sun's subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static GeoTime SolarSubpoint(
    this WgsModel ellipsoid,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarSubpoint ( _
    ellipsoid As WgsModel, _
    utc As DateTime, _
    kmLoft As Double _
) As GeoTime
Visual C++
[ExtensionAttribute]
public:
static GeoTime^ SolarSubpoint(
    WgsModel^ ellipsoid,
    DateTime utc,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
utc
Type: System..::..DateTime
Time of calculation, UTC
kmLoft
Type: System..::..Double
Desired height of subpoint above the ellipsoid model, in kilometers.

Return Value

The geodetic coordinates of the Sun's subpoint at the given time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SolarSubpoint Overload


SolarSubpoint Method (, , Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarSubpoint Method (, , Double)
Track Class See Also Send Feedback
Calculates the Sun's subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static GeoTime SolarSubpoint(
    this WgsModel ellipsoid,
    Julian date,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarSubpoint ( _
    ellipsoid As WgsModel, _
    date As Julian, _
    kmLoft As Double _
) As GeoTime
Visual C++
[ExtensionAttribute]
public:
static GeoTime^ SolarSubpoint(
    WgsModel^ ellipsoid,
    Julian^ date,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
date
Type: Julian
Time of calculation.
kmLoft
Type: System..::..Double
Desired height of subpoint above the ellipsoid model, in kilometers.

Return Value

The geodetic coordinates of the Sun's subpoint at the given time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SolarSubpoint Overload


SolarSubpointEcf Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SolarSubpointEcf Method
Track Class See Also Send Feedback

Overload List

Name | Description
SolarSubpointEcf(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpointEcf(WgsModel, Julian, Double) | Calculates the Sun's subpoint.

See Also

Track Class
Track Members


SolarSubpointEcf Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarSubpointEcf Method (, DateTime, Double)
Track Class See Also Send Feedback
Calculates the Sun's subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EcfTime SolarSubpointEcf(
    this WgsModel ellipsoid,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarSubpointEcf ( _
    ellipsoid As WgsModel, _
    utc As DateTime, _
    kmLoft As Double _
) As EcfTime
Visual C++
[ExtensionAttribute]
public:
static EcfTime^ SolarSubpointEcf(
    WgsModel^ ellipsoid,
    DateTime utc,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
utc
Type: System..::..DateTime
Time of calculation, UTC
kmLoft
Type: System..::..Double
Desired height of subpoint above the ellipsoid model, in kilometers.

Return Value

The ECF-time coordinates of the Sun's subpoint at the given time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SolarSubpointEcf Overload


SolarSubpointEcf Method (, , Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarSubpointEcf Method (, , Double)
Track Class See Also Send Feedback
Calculates the Sun's subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EcfTime SolarSubpointEcf(
    this WgsModel ellipsoid,
    Julian date,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarSubpointEcf ( _
    ellipsoid As WgsModel, _
    date As Julian, _
    kmLoft As Double _
) As EcfTime
Visual C++
[ExtensionAttribute]
public:
static EcfTime^ SolarSubpointEcf(
    WgsModel^ ellipsoid,
    Julian^ date,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
date
Type: Julian
Time of calculation.
kmLoft
Type: System..::..Double
Desired height of subpoint above the ellipsoid model, in kilometers.

Return Value

The ECF-time coordinates of the Sun's subpoint at the given time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SolarSubpointEcf Overload


SolarSubpointEci Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SolarSubpointEci Method
Track Class See Also Send Feedback

Overload List

Name | Description
SolarSubpointEci(WgsModel, DateTime, Double) | Calculates the Sun's subpoint.
SolarSubpointEci(WgsModel, Julian, Double) | Calculates the Sun's subpoint.

See Also

Track Class
Track Members


SolarSubpointEci Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarSubpointEci Method (, DateTime, Double)
Track Class See Also Send Feedback
Calculates the Sun's subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EciTime SolarSubpointEci(
    this WgsModel ellipsoid,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarSubpointEci ( _
    ellipsoid As WgsModel, _
    utc As DateTime, _
    kmLoft As Double _
) As EciTime
Visual C++
[ExtensionAttribute]
public:
static EciTime^ SolarSubpointEci(
    WgsModel^ ellipsoid,
    DateTime utc,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
utc
Type: System..::..DateTime
Time of calculation, UTC
kmLoft
Type: System..::..Double
Desired height of subpoint above the ellipsoid model, in kilometers.

Return Value

The ECI-time coordinates of the Sun's subpoint at the given time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SolarSubpointEci Overload


SolarSubpointEci Method (, , Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarSubpointEci Method (, , Double)
Track Class See Also Send Feedback
Calculates the Sun's subpoint.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EciTime SolarSubpointEci(
    this WgsModel ellipsoid,
    Julian date,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarSubpointEci ( _
    ellipsoid As WgsModel, _
    date As Julian, _
    kmLoft As Double _
) As EciTime
Visual C++
[ExtensionAttribute]
public:
static EciTime^ SolarSubpointEci(
    WgsModel^ ellipsoid,
    Julian^ date,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
date
Type: Julian
Time of calculation.
kmLoft
Type: System..::..Double
Desired height of subpoint above the ellipsoid model, in kilometers.

Return Value

The ECI-time coordinates of the Sun's subpoint at the given time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SolarSubpointEci Overload


SolarTerminator Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SolarTerminator Method
Track Class See Also Send Feedback

Overload List

Name | Description
SolarTerminator(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminator(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.

See Also

Track Class
Track Members


SolarTerminator Method (, DateTime, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarTerminator Method (, DateTime, Double, Double)
Track Class See Also Send Feedback
Calculates a set of points that define Earth's daylight terminator line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> SolarTerminator(
    this WgsModel ellipsoid,
    DateTime utc,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarTerminator ( _
    ellipsoid As WgsModel, _
    utc As DateTime, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ SolarTerminator(
    WgsModel^ ellipsoid,
    DateTime utc,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
utc
Type: System..::..DateTime
Time of calculation (UTC).
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points, spaced in distance by "kmSpacing".

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The solar terminator line separates the illuminated daytime side of the Earth from the dark nighttime side.

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
SolarTerminator Overload


SolarTerminator Method (, , Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarTerminator Method (, , Double, Double)
Track Class See Also Send Feedback
Calculates a set of points that define Earth's daylight terminator line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Geo> SolarTerminator(
    this WgsModel ellipsoid,
    Julian date,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarTerminator ( _
    ellipsoid As WgsModel, _
    date As Julian, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Geo)
Visual C++
[ExtensionAttribute]
public:
static List<Geo^>^ SolarTerminator(
    WgsModel^ ellipsoid,
    Julian^ date,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
date
Type: Julian
Time of calculation.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points, spaced in distance by "kmSpacing".

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The solar terminator line separates the illuminated daytime side of the Earth from the dark nighttime side.

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
SolarTerminator Overload


SolarTerminatorEcf Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SolarTerminatorEcf Method
Track Class See Also Send Feedback

Overload List

Name | Description
SolarTerminatorEcf(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEcf(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.

See Also

Track Class
Track Members


SolarTerminatorEcf Method (, DateTime, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarTerminatorEcf Method (, DateTime, Double, Double)
Track Class See Also Send Feedback
Calculates a set of points that define Earth's daylight terminator line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> SolarTerminatorEcf(
    this WgsModel ellipsoid,
    DateTime utc,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarTerminatorEcf ( _
    ellipsoid As WgsModel, _
    utc As DateTime, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ SolarTerminatorEcf(
    WgsModel^ ellipsoid,
    DateTime utc,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
utc
Type: System..::..DateTime
Time of calculation (UTC).
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points, spaced in distance by "kmSpacing".

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The solar terminator line separates the illuminated daytime side of the Earth from the dark nighttime side.

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
SolarTerminatorEcf Overload


SolarTerminatorEcf Method (, , Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarTerminatorEcf Method (, , Double, Double)
Track Class See Also Send Feedback
Calculates a set of points that define Earth's daylight terminator line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Ecf> SolarTerminatorEcf(
    this WgsModel ellipsoid,
    Julian date,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarTerminatorEcf ( _
    ellipsoid As WgsModel, _
    date As Julian, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Ecf)
Visual C++
[ExtensionAttribute]
public:
static List<Ecf^>^ SolarTerminatorEcf(
    WgsModel^ ellipsoid,
    Julian^ date,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
date
Type: Julian
Time of calculation.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the ellipsoid model, in kilometers.

Return Value

A list of geodetic coordinate points, spaced in distance by "kmSpacing".

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The solar terminator line separates the illuminated daytime side of the Earth from the dark nighttime side.

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
SolarTerminatorEcf Overload


SolarTerminatorEci Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SolarTerminatorEci Method
Track Class See Also Send Feedback

Overload List

Name | Description
SolarTerminatorEci(WgsModel, DateTime, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.
SolarTerminatorEci(WgsModel, Julian, Double, Double) | Calculates a set of points that define Earth's daylight terminator line.

See Also

Track Class
Track Members


SolarTerminatorEci Method (, DateTime, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarTerminatorEci Method (, DateTime, Double, Double)
Track Class See Also Send Feedback
Calculates a set of points that define Earth's daylight terminator line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> SolarTerminatorEci(
    this WgsModel ellipsoid,
    DateTime utc,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarTerminatorEci ( _
    ellipsoid As WgsModel, _
    utc As DateTime, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ SolarTerminatorEci(
    WgsModel^ ellipsoid,
    DateTime utc,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
utc
Type: System..::..DateTime
Time of calculation (UTC).
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points, spaced in distance by "kmSpacing".

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The solar terminator line separates the illuminated daytime side of the Earth from the dark nighttime side.

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
SolarTerminatorEci Overload


SolarTerminatorEci Method (, , Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SolarTerminatorEci Method (, , Double, Double)
Track Class See Also Send Feedback
Calculates a set of points that define Earth's daylight terminator line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static List<Eci> SolarTerminatorEci(
    this WgsModel ellipsoid,
    Julian date,
    double kmSpacing,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SolarTerminatorEci ( _
    ellipsoid As WgsModel, _
    date As Julian, _
    kmSpacing As Double, _
    kmLoft As Double _
) As List(Of Eci)
Visual C++
[ExtensionAttribute]
public:
static List<Eci^>^ SolarTerminatorEci(
    WgsModel^ ellipsoid,
    Julian^ date,
    double kmSpacing,
    double kmLoft
)

Parameters

ellipsoid
Type: WgsModel
The earth ellipsoid model.
date
Type: Julian
Time of calculation.
kmSpacing
Type: System..::..Double
The distance between each point, in kilometers.
kmLoft
Type: System..::..Double
The height of the set of points above the ellipsoid model, in kilometers.

Return Value

A list of ECI coordinate points, spaced in distance by "kmSpacing".

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

The solar terminator line separates the illuminated daytime side of the Earth from the dark nighttime side.

The returned points do not always form a perfect circle due to the Earth's equatorial bulge.

See Also

Track Class
SolarTerminatorEci Overload


Subpoint Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..Subpoint Method
Track Class See Also Send Feedback

Overload List

Name | Description
Subpoint(IOrbit, DateTime, Double) | Returns the orbit subpoint at a given time.
Subpoint(IOrbit, Double, Double) | Returns the orbit subpoint at a given time.
Subpoint(Satellite, DateTime, Double) | Returns the satellite subpoint at a given time.
Subpoint(Satellite, Double, Double) | Returns the satellite subpoint at a given time.

See Also

Track Class
Track Members


Subpoint Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..Subpoint Method (, DateTime, Double)
Track Class See Also Send Feedback
Returns the orbit subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static GeoTime Subpoint(
    this IOrbit orbit,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Subpoint ( _
    orbit As IOrbit, _
    utc As DateTime, _
    kmLoft As Double _
) As GeoTime
Visual C++
[ExtensionAttribute]
public:
static GeoTime^ Subpoint(
    IOrbit^ orbit,
    DateTime utc,
    double kmLoft
)

Parameters

orbit
Type: IOrbit
The orbit.
utc
Type: System..::..DateTime
The time in UTC.
kmLoft
Type: System..::..Double
The desired height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The geographic coordinates of the orbit subpoint.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
Subpoint Overload


Subpoint Method (, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..Subpoint Method (, Double, Double)
Track Class See Also Send Feedback
Returns the orbit subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static GeoTime Subpoint(
    this IOrbit orbit,
    double mpe,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Subpoint ( _
    orbit As IOrbit, _
    mpe As Double, _
    kmLoft As Double _
) As GeoTime
Visual C++
[ExtensionAttribute]
public:
static GeoTime^ Subpoint(
    IOrbit^ orbit,
    double mpe,
    double kmLoft
)

Parameters

orbit
Type: IOrbit
The orbit.
mpe
Type: System..::..Double
The time, in minutes-past-epoch.
kmLoft
Type: System..::..Double
The desired height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The geographic coordinates of the orbit subpoint.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
Subpoint Overload


Subpoint Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..Subpoint Method (, DateTime, Double)
Track Class See Also Send Feedback
Returns the satellite subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static GeoTime Subpoint(
    this Satellite sat,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Subpoint ( _
    sat As Satellite, _
    utc As DateTime, _
    kmLoft As Double _
) As GeoTime
Visual C++
[ExtensionAttribute]
public:
static GeoTime^ Subpoint(
    Satellite^ sat,
    DateTime utc,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
utc
Type: System..::..DateTime
The time in UTC.
kmLoft
Type: System..::..Double
The desired height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The geographic coordinates of the satellite's subpoint.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
Subpoint Overload


Subpoint Method (, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..Subpoint Method (, Double, Double)
Track Class See Also Send Feedback
Returns the satellite subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static GeoTime Subpoint(
    this Satellite sat,
    double mpe,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Subpoint ( _
    sat As Satellite, _
    mpe As Double, _
    kmLoft As Double _
) As GeoTime
Visual C++
[ExtensionAttribute]
public:
static GeoTime^ Subpoint(
    Satellite^ sat,
    double mpe,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
mpe
Type: System..::..Double
The time, in minutes-past-epoch.
kmLoft
Type: System..::..Double
The desired height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The geographic coordinates of the satellite's subpoint.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
Subpoint Overload


SubpointEcf Method

[image] [image]

OrbitTools Track Library Documentation
Track..::..SubpointEcf Method
Track Class See Also Send Feedback

Overload List

Name | Description
SubpointEcf(IOrbit, DateTime, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(IOrbit, Double, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(Satellite, DateTime, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.
SubpointEcf(Satellite, Double, Double) | Returns the ECF coordinate of a satellite subpoint at a given time.

See Also

Track Class
Track Members


SubpointEcf Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SubpointEcf Method (, DateTime, Double)
Track Class See Also Send Feedback
Returns the ECF coordinate of a satellite subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EcfTime SubpointEcf(
    this IOrbit orbit,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SubpointEcf ( _
    orbit As IOrbit, _
    utc As DateTime, _
    kmLoft As Double _
) As EcfTime
Visual C++
[ExtensionAttribute]
public:
static EcfTime^ SubpointEcf(
    IOrbit^ orbit,
    DateTime utc,
    double kmLoft
)

Parameters

orbit
Type: IOrbit
The satellite.
utc
Type: System..::..DateTime
The time in UTC.
kmLoft
Type: System..::..Double
The height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The orbit subpoint, in ECF coordinates.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SubpointEcf Overload


SubpointEcf Method (, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SubpointEcf Method (, Double, Double)
Track Class See Also Send Feedback
Returns the ECF coordinate of a satellite subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EcfTime SubpointEcf(
    this IOrbit orbit,
    double mpe,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SubpointEcf ( _
    orbit As IOrbit, _
    mpe As Double, _
    kmLoft As Double _
) As EcfTime
Visual C++
[ExtensionAttribute]
public:
static EcfTime^ SubpointEcf(
    IOrbit^ orbit,
    double mpe,
    double kmLoft
)

Parameters

orbit
Type: IOrbit
The orbit.
mpe
Type: System..::..Double
The time, in minutes-past-epoch.
kmLoft
Type: System..::..Double
The height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The orbit subpoint, in ECF coordinates.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SubpointEcf Overload


SubpointEcf Method (, DateTime, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SubpointEcf Method (, DateTime, Double)
Track Class See Also Send Feedback
Returns the ECF coordinate of a satellite subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EcfTime SubpointEcf(
    this Satellite sat,
    DateTime utc,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SubpointEcf ( _
    sat As Satellite, _
    utc As DateTime, _
    kmLoft As Double _
) As EcfTime
Visual C++
[ExtensionAttribute]
public:
static EcfTime^ SubpointEcf(
    Satellite^ sat,
    DateTime utc,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
utc
Type: System..::..DateTime
The time in UTC.
kmLoft
Type: System..::..Double
The height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The location of the satellite's subpoint, in ECF coordinates.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SubpointEcf Overload


SubpointEcf Method (, Double, Double)

[image]

OrbitTools Track Library Documentation
Track..::..SubpointEcf Method (, Double, Double)
Track Class See Also Send Feedback
Returns the ECF coordinate of a satellite subpoint at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static EcfTime SubpointEcf(
    this Satellite sat,
    double mpe,
    double kmLoft
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SubpointEcf ( _
    sat As Satellite, _
    mpe As Double, _
    kmLoft As Double _
) As EcfTime
Visual C++
[ExtensionAttribute]
public:
static EcfTime^ SubpointEcf(
    Satellite^ sat,
    double mpe,
    double kmLoft
)

Parameters

sat
Type: Satellite
The satellite.
mpe
Type: System..::..Double
The time, in minutes-past-epoch.
kmLoft
Type: System..::..Double
The height of the subpoint above the earth ellipsoid model, in kilometers.

Return Value

The location of the satellite's subpoint, in ECF coordinates.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Satellite. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Track Class
SubpointEcf Overload


Utility Class

[image]

OrbitTools Track Library Documentation
Utility Class
Members See Also Send Feedback
Class containing miscellaneous utility functions.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static class Utility
Visual Basic
<ExtensionAttribute> _
Public NotInheritable Class Utility
Visual C++
[ExtensionAttribute]
public ref class Utility abstract sealed

Inheritance Hierarchy

System..::..Object
Zeptomoby.OrbitTools.Track..::..Utility

See Also

Utility Members


Utility Members

[image] [image]

OrbitTools Track Library Documentation
Utility Members
Utility Class Methods See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
CalcDecayTime(IOrbit, DateTime, DateTime) | Searches for the time when a satellite orbit decays.
CalcDecayTime(IOrbit, Double, Double) | Searches for the time when a satellite orbit decays.
Intersection | Returns the point where a line intersects an ellipsoid model.
LineIntersects | Returns true if a line between two points intersects an earth ellipsoid model.
MidPoint | Determines the point that represents the middle of a line between two points.
MpeToTime | Converts a minutes-past-epoch value into a DateTime value.
NearestSecond | Rounds a DateTime value to the nearest second.
RevAtTime(IOrbit, DateTime) | Determines the orbit revolution number at a given time.
RevAtTime(IOrbit, Double) | Determines the orbit revolution number at a given time.
SurfaceDistance | Calculates the distance between the surface of an ellipsoid model and the closest point on a line.
TimeToMpe | Converts a DateTime value into a minutes-past-epoch value.

See Also

Utility Class


Utility Methods

[image] [image]

OrbitTools Track Library Documentation
Utility Methods
Utility Class See Also Send Feedback

The Utility type exposes the following members.

Methods

Name | Description
CalcDecayTime(IOrbit, DateTime, DateTime) | Searches for the time when a satellite orbit decays.
CalcDecayTime(IOrbit, Double, Double) | Searches for the time when a satellite orbit decays.
Intersection | Returns the point where a line intersects an ellipsoid model.
LineIntersects | Returns true if a line between two points intersects an earth ellipsoid model.
MidPoint | Determines the point that represents the middle of a line between two points.
MpeToTime | Converts a minutes-past-epoch value into a DateTime value.
NearestSecond | Rounds a DateTime value to the nearest second.
RevAtTime(IOrbit, DateTime) | Determines the orbit revolution number at a given time.
RevAtTime(IOrbit, Double) | Determines the orbit revolution number at a given time.
SurfaceDistance | Calculates the distance between the surface of an ellipsoid model and the closest point on a line.
TimeToMpe | Converts a DateTime value into a minutes-past-epoch value.

See Also

Utility Class


CalcDecayTime Method

[image] [image]

OrbitTools Track Library Documentation
Utility..::..CalcDecayTime Method
Utility Class See Also Send Feedback

Overload List

Name | Description
CalcDecayTime(IOrbit, DateTime, DateTime) | Searches for the time when a satellite orbit decays.
CalcDecayTime(IOrbit, Double, Double) | Searches for the time when a satellite orbit decays.

See Also

Utility Class
Utility Members


CalcDecayTime Method (, DateTime, DateTime)

[image]

OrbitTools Track Library Documentation
Utility..::..CalcDecayTime Method (, DateTime, DateTime)
Utility Class See Also Send Feedback
Searches for the time when a satellite orbit decays.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static Nullable<DateTime> CalcDecayTime(
    this IOrbit orbit,
    DateTime t1,
    DateTime t2
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcDecayTime ( _
    orbit As IOrbit, _
    t1 As DateTime, _
    t2 As DateTime _
) As Nullable(Of DateTime)
Visual C++
[ExtensionAttribute]
public:
static Nullable<DateTime> CalcDecayTime(
    IOrbit^ orbit,
    DateTime t1,
    DateTime t2
)

Parameters

orbit
Type: IOrbit
The satellite orbit.
t1
Type: System..::..DateTime
The search start time.
t2
Type: System..::..DateTime
The search end time

Return Value

The time that the orbit decays, else null to indicate no decay condition detected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

For best results, always use a t1 value equal to the satellite orbit's epoch time.

See Also

Utility Class
CalcDecayTime Overload


CalcDecayTime Method (, Double, Double)

[image]

OrbitTools Track Library Documentation
Utility..::..CalcDecayTime Method (, Double, Double)
Utility Class See Also Send Feedback
Searches for the time when a satellite orbit decays.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static Nullable<double> CalcDecayTime(
    this IOrbit orbit,
    double t1,
    double t2
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function CalcDecayTime ( _
    orbit As IOrbit, _
    t1 As Double, _
    t2 As Double _
) As Nullable(Of Double)
Visual C++
[ExtensionAttribute]
public:
static Nullable<double> CalcDecayTime(
    IOrbit^ orbit,
    double t1,
    double t2
)

Parameters

orbit
Type: IOrbit
The satellite orbit.
t1
Type: System..::..Double
The search start time, in minutes-past-epoch format.
t2
Type: System..::..Double
The search end time, in minutes-past-epoch format.

Return Value

The time, in minutes-past-epoch, that the orbit decays, else null to indicate no decay condition detected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

Remarks

For best results, always use a t1 value equal to the satellite orbit's epoch time.

See Also

Utility Class
CalcDecayTime Overload


Intersection Method

[image]

OrbitTools Track Library Documentation
Utility..::..Intersection Method
Utility Class See Also Send Feedback
Returns the point where a line intersects an ellipsoid model.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static Vector Intersection(
    this WgsModel ellipsoid,
    Vector p1,
    Vector p2
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function Intersection ( _
    ellipsoid As WgsModel, _
    p1 As Vector, _
    p2 As Vector _
) As Vector
Visual C++
[ExtensionAttribute]
public:
static Vector^ Intersection(
    WgsModel^ ellipsoid,
    Vector^ p1,
    Vector^ p2
)

Parameters

ellipsoid
Type: WgsModel
The ellipsoid model.
p1
Type: Vector
Line starting point, in ECI/ECF coordinate space.
p2
Type: Vector
Line ending point, in ECI/ECF coordinate space.

Return Value

The coordinates of the intersection point, or null to indicate that the line does not intersect the ellipsoid.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class


LineIntersects Method

[image]

OrbitTools Track Library Documentation
Utility..::..LineIntersects Method
Utility Class See Also Send Feedback
Returns true if a line between two points intersects an earth ellipsoid model.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static bool LineIntersects(
    this WgsModel model,
    Vector p1,
    Vector p2,
    double kmAltitude
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function LineIntersects ( _
    model As WgsModel, _
    p1 As Vector, _
    p2 As Vector, _
    kmAltitude As Double _
) As Boolean
Visual C++
[ExtensionAttribute]
public:
static bool LineIntersects(
    WgsModel^ model,
    Vector^ p1,
    Vector^ p2,
    double kmAltitude
)

Parameters

model
Type: WgsModel
The earth ellipsoid model.
p1
Type: Vector
Line starting point, in ECI coordinate space.
p2
Type: Vector
Line ending point, in ECI coordinate space.
kmAltitude
Type: System..::..Double
The minimum distance the line must be positioned near the ellipsoid surface to be considered intersecting.

Return Value

True if the line intersects, else false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class


MidPoint Method

[image]

OrbitTools Track Library Documentation
Utility..::..MidPoint Method
Utility Class See Also Send Feedback
Determines the point that represents the middle of a line between two points.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static Vector MidPoint(
    Vector pt1,
    Vector pt2
)
Visual Basic
Public Shared Function MidPoint ( _
    pt1 As Vector, _
    pt2 As Vector _
) As Vector
Visual C++
public:
static Vector^ MidPoint(
    Vector^ pt1,
    Vector^ pt2
)

Parameters

pt1
Type: Vector
The line's starting point.
pt2
Type: Vector
The line's ending point.

Return Value

The mid-point between the two points.

See Also

Utility Class


MpeToTime Method

[image]

OrbitTools Track Library Documentation
Utility..::..MpeToTime Method
Utility Class See Also Send Feedback
Converts a minutes-past-epoch value into a DateTime value.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static DateTime MpeToTime(
    this IOrbit orbit,
    double mpe
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function MpeToTime ( _
    orbit As IOrbit, _
    mpe As Double _
) As DateTime
Visual C++
[ExtensionAttribute]
public:
static DateTime MpeToTime(
    IOrbit^ orbit,
    double mpe
)

Parameters

orbit
Type: IOrbit
The satellite orbit.
mpe
Type: System..::..Double
The time to convert (minutes-past-epoch).

Return Value

A DateTime object representing the calculated time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class


NearestSecond Method

[image]

OrbitTools Track Library Documentation
Utility..::..NearestSecond Method
Utility Class See Also Send Feedback
Rounds a DateTime value to the nearest second.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static DateTime NearestSecond(
    this DateTime datetime
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function NearestSecond ( _
    datetime As DateTime _
) As DateTime
Visual C++
[ExtensionAttribute]
public:
static DateTime NearestSecond(
    DateTime datetime
)

Parameters

datetime
Type: System..::..DateTime
The time that will be rounded.

Return Value

The rounded value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class


RevAtTime Method

[image] [image]

OrbitTools Track Library Documentation
Utility..::..RevAtTime Method
Utility Class See Also Send Feedback

Overload List

Name | Description
RevAtTime(IOrbit, DateTime) | Determines the orbit revolution number at a given time.
RevAtTime(IOrbit, Double) | Determines the orbit revolution number at a given time.

See Also

Utility Class
Utility Members


RevAtTime Method (, DateTime)

[image]

OrbitTools Track Library Documentation
Utility..::..RevAtTime Method (, DateTime)
Utility Class See Also Send Feedback
Determines the orbit revolution number at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static int RevAtTime(
    this IOrbit orbit,
    DateTime utc
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function RevAtTime ( _
    orbit As IOrbit, _
    utc As DateTime _
) As Integer
Visual C++
[ExtensionAttribute]
public:
static int RevAtTime(
    IOrbit^ orbit,
    DateTime utc
)

Parameters

orbit
Type: IOrbit
The orbit.
utc
Type: System..::..DateTime
The target time, in UTC.

Return Value

The orbit revolution number.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class
RevAtTime Overload


RevAtTime Method (, Double)

[image]

OrbitTools Track Library Documentation
Utility..::..RevAtTime Method (, Double)
Utility Class See Also Send Feedback
Determines the orbit revolution number at a given time.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static int RevAtTime(
    this IOrbit orbit,
    double mpe
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function RevAtTime ( _
    orbit As IOrbit, _
    mpe As Double _
) As Integer
Visual C++
[ExtensionAttribute]
public:
static int RevAtTime(
    IOrbit^ orbit,
    double mpe
)

Parameters

orbit
Type: IOrbit
The orbit.
mpe
Type: System..::..Double
The target time, in minutes-past-epoch.

Return Value

The orbit revolution number.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class
RevAtTime Overload


SurfaceDistance Method

[image]

OrbitTools Track Library Documentation
Utility..::..SurfaceDistance Method
Utility Class See Also Send Feedback
Calculates the distance between the surface of an ellipsoid model and the closest point on a line.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static double SurfaceDistance(
    this WgsModel model,
    Vector p1,
    Vector p2
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function SurfaceDistance ( _
    model As WgsModel, _
    p1 As Vector, _
    p2 As Vector _
) As Double
Visual C++
[ExtensionAttribute]
public:
static double SurfaceDistance(
    WgsModel^ model,
    Vector^ p1,
    Vector^ p2
)

Parameters

model
Type: WgsModel
The ellipsoid model.
p1
Type: Vector
Line starting point, in ECI coordinate space.
p2
Type: Vector
Line ending point, in ECI coordinate space.

Return Value

The distance between the surface of the ellipsoid model and the nearest point on the line, in kilometers.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type WgsModel. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class


TimeToMpe Method

[image]

OrbitTools Track Library Documentation
Utility..::..TimeToMpe Method
Utility Class See Also Send Feedback
Converts a DateTime value into a minutes-past-epoch value.

Namespace: Zeptomoby.OrbitTools.Track
Assembly: Zeptomoby.OrbitTools.Track (in Zeptomoby.OrbitTools.Track.dll) Version: 1.5.0.0 (1.5.0.0)

Syntax

C#
public static double TimeToMpe(
    this IOrbit orbit,
    DateTime time
)
Visual Basic
<ExtensionAttribute> _
Public Shared Function TimeToMpe ( _
    orbit As IOrbit, _
    time As DateTime _
) As Double
Visual C++
[ExtensionAttribute]
public:
static double TimeToMpe(
    IOrbit^ orbit,
    DateTime time
)

Parameters

orbit
Type: IOrbit
The satellite orbit.
time
Type: System..::..DateTime
The time to convert.

Return Value

The total number of minutes past epoch.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IOrbit. When you use instance method syntax to call this method, omit the first parameter. For more information, see or .

See Also

Utility Class